summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorG. Branden Robinson <g.branden.robinson@gmail.com>2021-11-08 07:28:39 +1100
committerG. Branden Robinson <g.branden.robinson@gmail.com>2021-11-09 10:50:07 +1100
commit22a27624ecd9799497104ba1b0856a7264e338b8 (patch)
tree547e9cfee54542f03c18113ee73b5e43f30aeffb /configure.ac
parent39745aee1c07cf0fb0b21cf0bacfc9946fd9e9f0 (diff)
downloadgroff-git-22a27624ecd9799497104ba1b0856a7264e338b8.tar.gz
configure.ac: Add `strdup` to AC_CHECK_FUNCS.
* configure.ac: Add `strdup` to AC_CHECK_FUNCS since we are using it and the whole point of libgroff's `strsave()` was to get along without it. But `strdup` has been standardized in POSIX for 20 years (SUSv3, POSIX:2001) and is on its way into ISO standard C (N2354) and C++ (P2391R0) as well.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3e3324a5a..f9963a9cc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -135,7 +135,8 @@ LIBS="$LIBS $LIBC $LIBM"
AC_REPLACE_FUNCS([fmod getcwd putenv strcasecmp \
strerror strncasecmp strtol])
LIBS="$saved_libs"
-AC_CHECK_FUNCS([gettimeofday isatty kill rename setlocale strsep])
+AC_CHECK_FUNCS([gettimeofday isatty kill rename setlocale strdup \
+ strsep])
GROFF_MKSTEMP
AC_CHECK_DECLS([strsignal, getc_unlocked])
AC_CHECK_DECLS([sys_siglist, getc_unlocked])