summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2018-03-11 22:52:01 +0000
committerColin Watson <cjwatson@debian.org>2018-03-11 22:52:01 +0000
commit27cd0ce6758624a345265b31d20e31d0d9e869b2 (patch)
tree388d457946be2f8d050139a20f0c2eb93faaffec /configure.ac
parent3b4b85baa3e2a252a6480b3cfb9cf984eff1b71a (diff)
downloadgroff-git-27cd0ce6758624a345265b31d20e31d0d9e869b2.tar.gz
Switch to Gnulib implementation of snprintf
This is more actively maintained, straightforward to integrate now that we have Gnulib integration, and simplifies groff's overall licensing. * bootstrap.conf (gnulib_modules): Add `snprintf' and `vsnprintf'. * configure.ac: Remove local checks for `snprintf' and `vsnprintf'. * Makefile.am: Remove various comments related to local checks for `snprintf' and `vsnprintf'. * src/include/lib.h: Remove declarations of `snprintf' and `vsnprintf'. * src/libs/libgroff/libgroff.am (EXTRA_DIST): Remove `src/libs/snprintf/snprintf.c'. * src/libs/snprintf/snprintf.c: Remove. * LICENSES: Remove section about `src/libs/snprintf/snprintf.c'. * MANIFEST: Remove entry for `src/libs/libxutil'.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 1 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index f3c4dd051..956452615 100644
--- a/configure.ac
+++ b/configure.ac
@@ -93,12 +93,10 @@ GROFF_NEED_DECLARATION([popen])
GROFF_NEED_DECLARATION([pclose])
GROFF_NEED_DECLARATION([putenv])
GROFF_NEED_DECLARATION([rand])
-GROFF_NEED_DECLARATION([snprintf])
GROFF_NEED_DECLARATION([srand])
GROFF_NEED_DECLARATION([strcasecmp])
GROFF_NEED_DECLARATION([strncasecmp])
GROFF_NEED_DECLARATION([vfprintf])
-GROFF_NEED_DECLARATION([vsnprintf])
GROFF_SYS_NERR
GROFF_SYS_ERRLIST
GROFF_OSFCN_H
@@ -130,10 +128,8 @@ AC_SUBST([LIBEXT],[$acl_libext])
AC_FUNC_MMAP
saved_libs="$LIBS"
LIBS="$LIBS $LIBC $LIBM"
-AC_REPLACE_FUNCS([fmod getcwd putenv snprintf strcasecmp \
+AC_REPLACE_FUNCS([fmod getcwd putenv strcasecmp \
strerror strncasecmp strtol])
-# vsnprintf is in the same source file as snprintf
-AC_CHECK_FUNCS([vsnprintf], [], [AC_LIBOBJ([snprintf])])
LIBS="$saved_libs"
AC_CHECK_FUNCS([gettimeofday isatty kill rename setlocale strsep])
GROFF_MKSTEMP