summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorG. Branden Robinson <g.branden.robinson@gmail.com>2023-02-18 11:55:02 -0600
committerG. Branden Robinson <g.branden.robinson@gmail.com>2023-02-18 12:40:04 -0600
commit8316578166a73de1db05c555e640e9153ddc8d5d (patch)
treeccd5920c6daaed75be0fee03ad89b7474bfe4336 /configure.ac
parentec001d2a23a3b1740e8d004006c0fc0d7fb6e288 (diff)
downloadgroff-git-8316578166a73de1db05c555e640e9153ddc8d5d.tar.gz
[build]: Detangle pdfroff, gropdf config (2/2).
* m4/groff.m4: Give pdfroff its own Autoconf macros to handle dependency checking, build objectives, and user notice. (GROFF_PDFROFF_DEPENDENCIES_CHECK): New macro requires `GROFF_AWK_PATH` and `GROFF_GHOSTSCRIPT_PATH`, determines whether pdfroff can be used at build time, and (if not) constructs part of message to be shown to user explaining why. (GROFF_PDFROFF_PROGRAM_NOTICE): New macro requires `GROFF_PDFROFF_DEPENDENCIES_CHECK` and emits message if needed. (GROFF_GHOSTSCRIPT_AVAILABILITY_NOTICE): Drop mention of impact on pdfroff since its dedicated notice covers this now. * configure.ac: Call the new macros at appropriate times. Produce a new Automake macro, `USE_PDFROFF`, to replace inapposite use of `USE_GROPDF` in pdfmark.am. * contrib/pdfmark/pdfmark.am: Use `USE_PDFROFF` instead of `USE_GROPDF`.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 24082e5c9..b4e992162 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
# Autoconf configuration file for groff.
-# Copyright (C) 1989-2020 Free Software Foundation, Inc.
+# Copyright (C) 1989-2023 Free Software Foundation, Inc.
#
# This file is part of groff.
#
@@ -167,6 +167,7 @@ GROFF_TMAC
GROFF_WITH_COMPATIBILITY_WRAPPERS
GROFF_TARGET_PATH_SEPARATOR
GROFF_CHECK_GROHTML_PROGRAMS
+GROFF_PDFROFF_DEPENDENCIES_CHECK
GROFF_GROPDF_DEPENDENCIES_CHECK
GROFF_PNMTOOLS_CAN_BE_QUIET
GROFF_PNMTOPS_NOSETPAGE
@@ -201,6 +202,7 @@ AM_CONDITIONAL([MAKE_DEFINES_RM], [test "$groff_make_defines_rm" = yes])
AM_CONDITIONAL([USEPROGRAMPREFIX], [test "$g" = g])
AM_CONDITIONAL([USE_GROHTML], [test "$use_grohtml" = yes])
+AM_CONDITIONAL([USE_PDFROFF], [test "$use_pdfroff" = yes])
AM_CONDITIONAL([USE_GROPDF], [test "$use_gropdf" = yes])
AM_CONDITIONAL([USE_GROFF_ALLOCATOR],
[test "$groff_use_own_allocator" = yes])
@@ -264,4 +266,5 @@ GROFF_GHOSTSCRIPT_VERSION_NOTICE
GROFF_URW_FONTS_NOTICE
GROFF_UCHARDET_NOTICE
GROFF_GROHTML_PROGRAM_NOTICE
+GROFF_PDFROFF_PROGRAM_NOTICE
GROFF_GROPDF_PROGRAM_NOTICE