summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorG. Branden Robinson <g.branden.robinson@gmail.com>2022-05-20 14:40:56 -0500
committerG. Branden Robinson <g.branden.robinson@gmail.com>2022-05-21 11:13:08 -0500
commitaa5787c1eb1b388ab246a02cdbf2d9267e701494 (patch)
tree6bc02ab7c7ac220482101f475a44d6392b4f1f9d /configure.ac
parent03f60f5bac856481a6bd62b7c87bb5a3e70b6ada (diff)
downloadgroff-git-aa5787c1eb1b388ab246a02cdbf2d9267e701494.tar.gz
[build]: Refactor grohtml runtime-dep check.
Handle missing programs required at runtime by grohtml more gracefully. Rename and refactor configuration-time logic to be more understandable. * configure.ac: * m4/groff.m4: Rename `GROFF_HTML_PROGRAMS` macro to `GROFF_CHECK_GROHTML_PROGRAMS`. Rename shell variable `make_htmldoc` to `use_grohtml`. Set it explicitly to "no" or "yes" instead of null or not null. * configure.ac: * m4/groff.m4: * doc/doc.am: Rename `BUILD_HTML` to `USE_GROHTML`. * configure.ac: Call `GROFF_GROHTML_PROGRAM_NOTICE`. * doc/doc.am: Bracket definition of `PROCESSEDDOCFILES_HTML` macro and `$(PROCESSEDDOCFILES_HTML)` dependency declaration in Automake `if USE_GROHTML` conditional. This prevents an attempt to build an HTML version of the "pic.ms" document that is doomed to fail (noisily). * m4/groff.m4: Refactor grohtml runtime-dependency program check. Split into two macros: one (`GROFF_CHECK_GROHTML_PROGRAMS`) performs the check, the other (`GROFF_GROHTML_PROGRAM_NOTICE`) issues a notice at the end of the configuration process if at least one program was not found. Rename `html_docnote` shell variable to `grohtml_notice`. Tighten wording of notice. Drop unused `make_install_htmldoc` and `make_uninstall_htmldoc` shell variables. Also make code style more readable.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index eea5a8470..de79302a9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -163,7 +163,7 @@ GROFF_G
GROFF_TMAC
GROFF_WITH_COMPATIBILITY_WRAPPERS
GROFF_TARGET_PATH_SEPARATOR
-GROFF_HTML_PROGRAMS
+GROFF_CHECK_GROHTML_PROGRAMS
GROFF_PDFDOC_PROGRAMS
GROFF_PNMTOOLS_CAN_BE_QUIET
GROFF_PNMTOPS_NOSETPAGE
@@ -175,8 +175,8 @@ GROFF_GHOSTSCRIPT_VERSION_CHECK
gl_GLIBC21
gl_LOCALCHARSET
-# checks for presence of URW fonts (requires ghostscript, which is
-# checked in GROFF_HTML_PROGRAMS
+# Check for presence of URW fonts (these require Ghostscript, which is
+# checked for by GROFF_CHECK_GROHTML_PROGRAMS).
GROFF_URW_FONTS
AM_CONDITIONAL([BUILD_WINSCRIPTS], [test -n "$make_winscripts"])
@@ -197,7 +197,7 @@ AM_CONDITIONAL([MAKE_DONT_HAVE_RM], [test "$groff_is_rm_defined" = no])
# Some programs have a "g" prefix if an existing groff installation is detected
AM_CONDITIONAL([USEPROGRAMPREFIX], [test "$g" = g])
-AM_CONDITIONAL([BUILD_HTML], [test -n "$make_htmldoc"])
+AM_CONDITIONAL([USE_GROHTML], [test "$use_grohtml" = yes])
AM_CONDITIONAL([BUILD_PDFDOC], [test -n "$make_pdfdoc"])
AM_CONDITIONAL([USE_GROFF_ALLOCATOR], [test "$groff_use_own_allocator" = yes])
AM_CONDITIONAL([HAVE_PDFTOOLS], [test "$groff_have_pdftools" = yes ])
@@ -235,3 +235,4 @@ GROFF_APPRESDIR_CHECK
GROFF_URW_FONTS_CHECK
GROFF_UCHARDET_CHECK
GROFF_GHOSTSCRIPT_VERSION_NOTICE
+GROFF_GROHTML_PROGRAM_NOTICE