summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorG. Branden Robinson <g.branden.robinson@gmail.com>2022-05-20 07:32:30 -0500
committerG. Branden Robinson <g.branden.robinson@gmail.com>2022-05-21 11:13:08 -0500
commitb47aebc69ecd2d9855033441e9888e6d306ec904 (patch)
treed84d4b90eebbf1685ce871e8aa869b795d573fff /configure.ac
parent05f3c08562ba68d1d64081de45f7a073a8407e05 (diff)
downloadgroff-git-b47aebc69ecd2d9855033441e9888e6d306ec904.tar.gz
configure.ac: Revise configuration report.
* configure.ac: Revise configuration report for intelligibility. Add report of C++ compiler and flags used: we compile much more C++ than C code so this seems appropriate. Report Perl interpreter version so that we can collect build reports and turn the ratchet past Perl 5.6.1 at some point. Fix X11 "resources" misnomer (application defaults are what is meant). Rephrase generally.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 13 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 1ea4c377a..7993558b3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -209,27 +209,30 @@ AC_OUTPUT
echo "
${PACKAGE_NAME} version ${PACKAGE_VERSION}
----------------------------------------------------------------------
- Prefix : ${prefix}
- Compiler : ${CC} ${CFLAGS} ${CPPFLAGS}"
+ installation prefix : ${prefix}
+ C++ compiler : ${CXX} ${CXXFLAGS} ${CPPFLAGS}"
if test "x$use_groff_allocator" = "xyes"; then
echo "\
- Use groff allocator : yes"
+ use libgroff's memory allocator : yes"
else
echo "\
- Use groff allocator : no"
+ use libgroff's memory allocator : no"
fi
+echo "\
+ C compiler : ${CC} ${CFLAGS} ${CPPFLAGS}
+ Perl interpreter version : $perl_version"
if test "x$groff_no_x" = "xyes"; then
echo "\
- X11 support : no"
+ X11 support : disabled"
else
echo "\
- X11 support : yes
- X11 resources dir : $appresdir"
+ X11 support : enabled
+ X11 app defaults directory : $appresdir"
fi
echo "\
- URW fonts for pdf : $groff_have_urw_fonts
- Use uchardet library for preconv: $groff_have_uchardet
- pdftools for distcheck : $groff_have_pdftools"
+ use URW fonts for PDF output : $groff_have_urw_fonts
+ preconv can use uchardet library : $groff_have_uchardet
+ tests can use PDF tools : $groff_have_pdftools"
echo "\
----------------------------------------------------------------------"