summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorG. Branden Robinson <g.branden.robinson@gmail.com>2022-06-03 00:51:03 -0500
committerG. Branden Robinson <g.branden.robinson@gmail.com>2022-06-03 04:01:12 -0500
commitbf25f7ebf35c9ab384455edb1612494b4af46817 (patch)
treef74d475ac7fe0259b8a74fddf5f84c63a8f7143a /configure.ac
parentafa7128d7b939ca5c8cd082f2547f42e4e563674 (diff)
downloadgroff-git-bf25f7ebf35c9ab384455edb1612494b4af46817.tar.gz
[build]: Add Automake `HAVE_URW_FONTS` condition.
* configure.ac: Add `AM_CONDITIONAL`: `HAVE_URW_FONTS`, so our Automake files can more easily cope with their absence. * contrib/mom/mom.am (MOMPROCESSEDEXAMPLEFILES): Include "typesetting.pdf" only if `HAVE_URW_FONTS`, since the document demands them. * font/devpdf/Foundry.in: Add easily matched phrases to comments, to clearly delimit the URW foundry portion of the file so it can be omitted if those fonts are absent. * font/devpdf/devpdf.am (font/devpdf/Foundry): Generate file differently depending on `HAVE_URW_FONTS`; keep the existing procedure if true, and delete the URW section from the generated file otherwise, avoiding diagnostic messages from afmtodit(1) and our BuildFoundries script. Also update comments in Foundry.in file to be more helpful.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6090971ce..26a24366f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -204,6 +204,7 @@ AM_CONDITIONAL([USE_GROHTML], [test "$use_grohtml" = yes])
AM_CONDITIONAL([USE_GROPDF], [test "$use_gropdf" = yes])
AM_CONDITIONAL([USE_GROFF_ALLOCATOR],
[test "$groff_use_own_allocator" = yes])
+AM_CONDITIONAL([HAVE_URW_FONTS], [test "$groff_have_urw_fonts" = yes ])
AM_CONDITIONAL([HAVE_PDFTOOLS], [test "$groff_have_pdftools" = yes ])
AM_CONDITIONAL([HAVE_TEXI2DVI], [test "$groff_have_texi2dvi" = yes ])