summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorG. Branden Robinson <g.branden.robinson@gmail.com>2021-11-11 19:58:02 +1100
committerG. Branden Robinson <g.branden.robinson@gmail.com>2021-11-12 11:20:19 +1100
commitd79c3f3a4a19f7bf616a69558c4d3ce13690f441 (patch)
tree2f39fb82aeb3105e0e51f6b86ead16531202b144 /configure.ac
parent8080238bcc2deeaa70103dd8d52b90bc123e8628 (diff)
downloadgroff-git-d79c3f3a4a19f7bf616a69558c4d3ce13690f441.tar.gz
Revamp Texinfo manual handling, part one.
Drop `BUILD_INFODOC` symbol. Ship manual in GNU Info, text, and HTML forms in distribution archive. * Makefile.am (MAINTAINERCLEANFILES): Initialize. (MOSTLYCLEANADD): Drop unused variable. * configure.ac: Drop `AM_CONDITIONAL([BUILD_INFODOC]...`. * doc/doc.am (EXTRA_DIST): Rearrange shipment of our Texinfo manual source files to precede all of the generated forms, for clarity. Drop all `BUILD_INFODOC` conditionals. Make `build_infodoc` phony target depend on plain text, GNU Info, and HTML forms of Texinfo manual unconditionally. Also drop unused variables `groffinfodir`, `groffpdfdir`, and `texi2dvi_missing`. (EXTRA_DIST, MAINTAINERCLEANFILES): Add Info form of manual. Drop glob pattern attempting to match the segments that `makeinfo` breaks it into. It isn't necessary for MAINTAINERCLEANFILES. (EXTRA_DIST, MAINTAINERCLEANFILES): Add text form of manual. (EXTRA_DIST, MAINTAINERCLEANFILES): Add HTML form of manual. (dist-hook): Depend on new (phony) target `dist-info-bits`. (dist-info-bits): Look for the info document in the build directory, then the source directory. (It could be in either place depending on whether the build from a Git working tree is being done in or out of a separate build directory.) When found, copy the segments to the assembly area for the distribution archive. (install_infodoc): Refactor. Remove any groff info files from the destination info directory using a shell glob directly instead of a partly redundant ls(1) command substitution. Similarly, use a shell glob to cp(1) the info files (including any matched segments) to the destination info directory before running `install-info`. (In this process I learned that `install-info` doesn't "install" anything; instead, it (de-)registers info files with their top-level catalog.) Tested by building: 1. from Git working tree with separate build directory; 2. from distribution archive w/ separate build directory (`distcheck`); 3. from distribution archive directly; 4. from Git working tree directly.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 0 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index cdc425b04..e65a2d1c8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -195,7 +195,6 @@ AM_CONDITIONAL([MAKE_DONT_HAVE_RM], [test "x$groff_is_rm_defined" = "xno"])
# Some programs have a "g" prefix if an existing groff installation is detected
AM_CONDITIONAL([USEPROGRAMPREFIX], [test x$g = xg])
-AM_CONDITIONAL([BUILD_INFODOC], [test -n "$make_infodoc"])
AM_CONDITIONAL([BUILD_HTML], [test -n "$make_htmldoc"])
AM_CONDITIONAL([BUILD_HTMLEXAMPLES], [test -n "$make_htmlexamples"])
AM_CONDITIONAL([BUILD_PDFDOC], [test -n "$make_pdfdoc"])