summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorwlemb <wlemb>2001-08-19 21:32:25 +0000
committerwlemb <wlemb>2001-08-19 21:32:25 +0000
commiteaf33277027de8b8f5a104db588b38e2eddb0ceb (patch)
tree20e1b89778b74e4665e7820eda994786caeebd2b /configure.ac
parent553ad14abef58812d0b3c49b610dd82c54c30637 (diff)
downloadgroff-eaf33277027de8b8f5a104db588b38e2eddb0ceb.tar.gz
Use a config.h file.
* src/include/lib.h: Include config.h. * All C files: Ditto (if necessary). * All C++ source and header files: Include lib.h first (if necessary). * src/include/config.hin: New file (autogenerated by autoheader). * stamp-h.in: New file. * configure.ac: Updated. * aclocal.m4: Add third parameters to AC_DEFINE macros. (GROFF_ARRAY_DELETE): Simplified. * Makefile.sub (DISTCLEANFILES): Updated. Added targets for remaking config.status, config.hin, config.h, stamp-h.in, and stamp-h. * configure: Regenerated. * NEWS: Updated.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d8ac6879..b38fc57a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,6 @@
dnl Process this file with autoconf to produce a configure script.
AC_INIT
+AC_CONFIG_HEADERS(src/include/config.h:src/include/config.hin)
AC_CONFIG_SRCDIR([src/roff/groff/groff.cc])
dnl checks for programs
GROFF_SRCDIR
@@ -66,5 +67,6 @@ GROFF_PAGE
GROFF_G
GROFF_TMAC
$srcdir/mkinstalldirs src/xditview
+AC_CONFIG_FILES(stamp-h, [echo timestamp > stamp-h])
AC_CONFIG_FILES([Makefile src/xditview/Imakefile])
AC_OUTPUT