summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorwlemb <wlemb>2000-05-31 14:18:41 +0000
committerwlemb <wlemb>2000-05-31 14:18:41 +0000
commit8e3dd5967e77a57e8e2359e80421686ed0f9c622 (patch)
tree0ebf8d45f42e54635deeba0dcbeba2e68e368490 /configure.in
parentbbc23036e5152f165a47f9247c4bfbed293bfd31 (diff)
downloadgroff-8e3dd5967e77a57e8e2359e80421686ed0f9c622.tar.gz
* src/devices/grolbp/lbp.cc (set_papersizes): Add declaration of
strncasecmp(). * aclocal.m4 (GROFF_SRAND): New function to test the return value of srand() -- at least SunOS 4.1.3 uses `int' instead of `void'. * configure.in: Use it. * src/preproc/pic/pic.y, src/preproc/pic/pic.cc: Use it. * configure, Makefile.in: Updated. * configure.in: Add test for strncasecmp(). * src/include/lib.h: Use it.
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 0521b8ff..6d12d542 100755
--- a/configure.in
+++ b/configure.in
@@ -24,6 +24,7 @@ GROFF_POSIX
GROFF_PUTENV
GROFF_POPEN
GROFF_PCLOSE
+GROFF_SRAND
GROFF_SYS_NERR
GROFF_SYS_ERRLIST
GROFF_HYPOT
@@ -41,7 +42,7 @@ saved_libs="$LIBS"
LIBS="$LIBS -lc $LIBM"
AC_REPLACE_FUNCS(fmod strtol getcwd strerror putenv)
LIBS="$saved_libs"
-AC_CHECK_FUNCS(rename mkstemp strcasecmp strsep strdup)
+AC_CHECK_FUNCS(rename mkstemp strcasecmp strncasecmp strsep strdup)
AC_DECL_SYS_SIGLIST
dnl checks for compiler characteristics
GROFF_ARRAY_DELETE