summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorGurkirpal Singh <gurkirpal204@gmail.com>2017-07-04 03:15:00 +0530
committerNicolas Dufresne <nicolas.dufresne@collabora.com>2017-07-05 17:27:27 -0400
commit043b4177172f69807d02b6bceff41d700157c4e7 (patch)
treee1fea0983cddb14e6dbedf5e44a021cde637ce8d /meson.build
parenteed49b4231a063639f90279c8044404c2149902a (diff)
downloadgst-omx-043b4177172f69807d02b6bceff41d700157c4e7.tar.gz
meson: Add tizonia option
https://bugzilla.gnome.org/show_bug.cgi?id=782800
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 7 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 042bf60..ae618b2 100644
--- a/meson.build
+++ b/meson.build
@@ -17,7 +17,7 @@ endif
glib_req = '>= 2.40.0'
gst_req = '>= @0@.@1@.0'.format(gst_version_major, gst_version_minor)
-
+tizil_req = '>= 0.1.0'
api_version = '1.0'
soversion = 0
# maintaining compatibility with the previous libtool versioning
@@ -235,6 +235,12 @@ elif omx_target == 'bellagio'
cdata.set('USE_OMX_TARGET_BELLAGIO', 1)
elif omx_target == 'zynqultrascaleplus'
cdata.set('USE_OMX_TARGET_ZYNQ_USCALE_PLUS', 1)
+elif omx_target == 'tizonia'
+ cdata.set('USE_OMX_TARGET_TIZONIA', 1)
+ tizil_dep = dependency('tizilheaders', version : tizil_req)
+ cdata.set('TIZONIA_LIBDIR', tizil_dep.get_pkgconfig_variable('libdir'))
+ tizil_includedir = tizil_dep.get_pkgconfig_variable('includedir')
+ add_global_arguments('-I' + tizil_includedir + '/tizonia', language : 'C')
else
error ('Unsupported omx target specified. Use the -Dwith_omx_target option')
endif