summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2017-07-12 11:01:15 +0200
committerNicolas Dufresne <nicolas.dufresne@collabora.com>2017-09-06 14:50:18 -0400
commitcf9f1903db84a1e6745de26455baec9a7d138a1b (patch)
treec217c5dae1f6afa429e774512a41b461ffd41d43 /meson.build
parent79df3b0e8e003304808fc5d62d3bd8903386b108 (diff)
downloadgst-omx-cf9f1903db84a1e6745de26455baec9a7d138a1b.tar.gz
omxh265enc: add H265 encoder
The OMX spec doesn't support HEVC but the OMX stack of the zynqultrascaleplus adds it as a custom extension. It uses the same API as the one of Android's OMX stack. I used the H264 encoder code as a template. https://bugzilla.gnome.org/show_bug.cgi?id=785434
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 07c1a4a..5c6425b 100644
--- a/meson.build
+++ b/meson.build
@@ -228,6 +228,16 @@ if have_omx_theora
cdata.set('HAVE_THEORA', 1)
endif
+have_omx_hevc = cc.has_header_symbol(
+ 'OMX_Video.h',
+ 'OMX_VIDEO_CodingHEVC',
+ prefix : extra_video_headers,
+ args : gst_omx_args,
+ required : false)
+if have_omx_hevc
+ cdata.set('HAVE_HEVC', 1)
+endif
+
default_omx_struct_packing = 0
omx_target = get_option ('with_omx_target')
if omx_target == 'generic'