summaryrefslogtreecommitdiff
path: root/omx/Makefile.am
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian.droege@collabora.co.uk>2013-03-18 16:06:54 +0100
committerSebastian Dröge <sebastian.droege@collabora.co.uk>2013-03-18 16:34:51 +0100
commit0f5e6e967bcaf83af8fde0b51327295666192634 (patch)
tree1e3fcd6731e30b43f3dbc8e2a7d591f72613849b /omx/Makefile.am
parenta2ba5c67136e78b697a2e39830d0668c67411bbc (diff)
downloadgst-omx-0f5e6e967bcaf83af8fde0b51327295666192634.tar.gz
omx: Add VP8 decoder support
Diffstat (limited to 'omx/Makefile.am')
-rw-r--r--omx/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/omx/Makefile.am b/omx/Makefile.am
index da650c8..adbc9ab 100644
--- a/omx/Makefile.am
+++ b/omx/Makefile.am
@@ -1,5 +1,10 @@
plugin_LTLIBRARIES = libgstomx.la
+if HAVE_VP8
+VP8_C_FILES=gstomxvp8dec.c
+VP8_H_FILES=gstomxvp8dec.h
+endif
+
libgstomx_la_SOURCES = \
gstomx.c \
gstomxvideodec.c \
@@ -9,6 +14,7 @@ libgstomx_la_SOURCES = \
gstomxmpeg2dec.c \
gstomxh264dec.c \
gstomxh263dec.c \
+ $(VP8_C_FILES) \
gstomxwmvdec.c \
gstomxmpeg4videoenc.c \
gstomxh264enc.c \
@@ -24,6 +30,7 @@ noinst_HEADERS = \
gstomxmpeg4videodec.h \
gstomxh264dec.h \
gstomxh263dec.h \
+ $(VP8_H_FILES) \
gstomxwmvdec.h \
gstomxmpeg4videoenc.h \
gstomxh264enc.h \