summaryrefslogtreecommitdiff
path: root/omx/meson.build
diff options
context:
space:
mode:
authorGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2018-01-30 10:31:03 +0100
committerNicolas Dufresne <nicolas.dufresne@collabora.com>2018-01-30 11:54:37 +0000
commit13a43757f592e6ad14dc9d0eee214fd0e840842b (patch)
tree04dad0b742d61c0a40db1a0b56f60f600018db2c /omx/meson.build
parentf0469c99d2c05497991650ebf402095b1711e5f4 (diff)
downloadgst-omx-13a43757f592e6ad14dc9d0eee214fd0e840842b.tar.gz
meson: simplify OMX extensions detection
We are now always checking which files are present or not, even when using our internal copy of OMX, rather than hardcoding the ones present in it. https://bugzilla.gnome.org/show_bug.cgi?id=792043
Diffstat (limited to 'omx/meson.build')
-rw-r--r--omx/meson.build7
1 files changed, 1 insertions, 6 deletions
diff --git a/omx/meson.build b/omx/meson.build
index ca0dccd..b68cc55 100644
--- a/omx/meson.build
+++ b/omx/meson.build
@@ -26,7 +26,6 @@ omx_sources = [
'gstomxmp3enc.c',
]
-extra_inc = []
extra_c_args = []
if have_omx_vp8
@@ -43,10 +42,6 @@ if have_omx_hevc
omx_sources += 'gstomxh265dec.c'
endif
-if not have_external_omx
- extra_inc += include_directories ('openmax')
-endif
-
optional_deps = []
if gstgl_dep.found()
optional_deps += gstgl_dep
@@ -57,7 +52,7 @@ gstomx = library('gstomx',
omx_sources,
c_args : gst_omx_args + extra_c_args,
# link_args : noseh_link_args,
- include_directories : [configinc] + extra_inc,
+ include_directories : [configinc, omx_inc],
dependencies : [gstvideo_dep, gstaudio_dep, gstbase_dep, gstcontroller_dep,
libm, gmodule_dep, gstallocators_dep] + optional_deps,
install : true,