summaryrefslogtreecommitdiff
path: root/omx/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'omx/Makefile.am')
-rw-r--r--omx/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/omx/Makefile.am b/omx/Makefile.am
index dbe2f54..ed48e55 100644
--- a/omx/Makefile.am
+++ b/omx/Makefile.am
@@ -11,6 +11,7 @@ THEORA_H_FILES=gstomxtheoradec.h
endif
libgstomx_la_SOURCES = \
+ $(top_builddir)/gstomx_config.c \
gstomx.c \
gstomxvideodec.c \
gstomxvideoenc.c \
@@ -28,6 +29,19 @@ libgstomx_la_SOURCES = \
gstomxh263enc.c \
gstomxaacenc.c
+if USE_OMX_TARGET_TEGRA
+libgstomx_la_SOURCES += \
+ gstomxvideosink.c \
+ gstnvhdmioverlaysink.c \
+ gstnvoverlaysink.c \
+ gstomxaudiodec.c \
+ gstomxaacdec.c \
+ gstomxamrnbdec.c \
+ gstomxamrwbdec.c \
+ gstomxmpegaudiodec.c \
+ gstomxvp8enc.c
+endif
+
noinst_HEADERS = \
gstomx.h \
gstomxvideodec.h \
@@ -46,6 +60,19 @@ noinst_HEADERS = \
gstomxh263enc.h \
gstomxaacenc.h
+if USE_OMX_TARGET_TEGRA
+noinst_HEADERS += \
+ gstomxvideosink.h \
+ gstnvhdmioverlaysink.h \
+ gstnvoverlaysink.h \
+ gstomxaudiodec.h \
+ gstomxaacdec.h \
+ gstomxamrnbdec.h \
+ gstomxamrwbdec.h \
+ gstomxmpegaudiodec.h \
+ gstomxvp8enc.h
+endif
+
if !HAVE_EXTERNAL_OMX
OMX_INCLUDEPATH = -I$(abs_srcdir)/openmax
endif