summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVíctor Manuel Jáquez Leal <vjaquez@igalia.com>2015-04-14 10:08:47 +0200
committerVíctor Manuel Jáquez Leal <vjaquez@igalia.com>2015-04-14 11:36:13 +0200
commit3eb7986409b900abf1261b8e94ad08afba69d1b6 (patch)
treecfbab2118cc5c05bdf2d968604904e57c425973a /configure.ac
parent25382f3d91c96d79e72b83e788cffcb8252455ea (diff)
downloadgst-vaapi-3eb7986409b900abf1261b8e94ad08afba69d1b6.tar.gz
build: don't compile HEVC if not supported
HEVC decoding was added recently libva-1.5. This patch avoids HEVC decoding support in libgstvaapi if it is not available in the installed libva. https://bugzilla.gnome.org/show_bug.cgi?id=747831
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 72afb8aa..d86545f7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -955,6 +955,10 @@ AC_DEFINE_UNQUOTED(USE_VP8_DECODER, $USE_VP8_DECODER,
[Defined to 1 if VP8 decoder is used])
AM_CONDITIONAL(USE_VP8_DECODER, test $USE_VP8_DECODER -eq 1)
+AC_DEFINE_UNQUOTED(USE_HEVC_DECODER, $USE_HEVC_DECODER,
+ [Defined to 1 if HEVC decoder is used])
+AM_CONDITIONAL(USE_HEVC_DECODER, test $USE_HEVC_DECODER -eq 1)
+
AC_DEFINE_UNQUOTED(USE_DRM, $USE_DRM,
[Defined to 1 if DRM is enabled])
AM_CONDITIONAL(USE_DRM, test $USE_DRM -eq 1)