summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSreerenj Balachandran <sreerenj.balachandran@intel.com>2015-11-27 12:29:11 +0200
committerVíctor Manuel Jáquez Leal <victorx.jaquez@intel.com>2015-11-30 13:03:04 +0100
commitd7bd0a4c103db08a20368975eafd397b3fab6a9f (patch)
tree7fe72186d11953ae9da6ab5adca61f728919c590 /configure.ac
parent52eaafcd6c8f27d50ffff0ca8d18310d9378654b (diff)
downloadgst-vaapi-d7bd0a4c103db08a20368975eafd397b3fab6a9f.tar.gz
build: Add gmodule dependency for libgstvaapi_egl
https://bugzilla.gnome.org/show_bug.cgi?id=756259
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a8996dae..900fce8d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,6 +24,9 @@ m4_define([gst_vaapi_lt_age], [0])
# glib version number
m4_define([glib_version], [2.32])
+# gmodule version number
+m4_define([gmodule_version], [2.32])
+
# gstreamer version number
m4_define([gst_api_version], [autodetect])
m4_define([gst12_version], [1.1.90])
@@ -709,6 +712,11 @@ if test "$enable_egl" = "yes" -a $GLES_VERSION_MASK -ne 0; then
AC_CHECK_LIB([EGL], [eglGetDisplay], [:], [USE_EGL=0])
CPPFLAGS="$saved_CPPFLAGS"
LIBS="$saved_LIBS"
+
+ dnl Check for GMODULE
+ GMODULE_VERSION_REQUIRED=gmodule_version
+ PKG_CHECK_MODULES([GMODULE], [gmodule-2.0 >= $GMODULE_VERSION_REQUIRED])
+ AC_SUBST(GMODULE_VERSION_REQUIRED)
fi
dnl Check for Wayland