summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorGwenole Beauchesne <gwenole.beauchesne@intel.com>2012-07-23 14:15:42 +0200
committerGwenole Beauchesne <gwenole.beauchesne@intel.com>2012-07-23 15:18:18 +0200
commit0c8dc604cb3e0e803f83e16a3d30e943cb24ebe9 (patch)
tree9e0f6a9ae58381313368372a92770a28a166120c /tests/Makefile.am
parente58737db6e5e1a63e4077c4bd0385942c9f28e83 (diff)
downloadgst-vaapi-0c8dc604cb3e0e803f83e16a3d30e943cb24ebe9.tar.gz
tests: move encoded bitstreams to libutils.la.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am11
1 files changed, 4 insertions, 7 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index c6f73178..a2820b6a 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -42,10 +42,10 @@ TEST_LIBS += \
endif
test_codecs_source_c = test-mpeg2.c test-h264.c test-vc1.c test-jpeg.c
-test_codecs_source_h = $(test_codecs_source_c:%.c=%.h)
+test_codecs_source_h = $(test_codecs_source_c:%.c=%.h) test-decode.h
-test_utils_source_c = image.c
-test_utils_source_h = image.h
+test_utils_source_c = image.c $(test_codecs_source_c)
+test_utils_source_h = image.h $(test_codecs_source_h)
noinst_LTLIBRARIES = libutils.la
libutils_la_SOURCES = $(test_utils_source_c)
@@ -63,7 +63,7 @@ test_surfaces_SOURCES = test-surfaces.c
test_surfaces_CFLAGS = $(TEST_CFLAGS)
test_surfaces_LDADD = libutils.la $(TEST_LIBS)
-test_subpicture_SOURCES = test-subpicture.c test-mpeg2.c test-subpicture-data.c
+test_subpicture_SOURCES = test-subpicture.c test-subpicture-data.c
test_subpicture_CFLAGS = $(TEST_CFLAGS)
test_subpicture_LDADD = libutils.la $(TEST_LIBS)
@@ -76,11 +76,8 @@ test_textures_CFLAGS = $(TEST_CFLAGS)
test_textures_LDADD = libutils.la $(TEST_LIBS)
EXTRA_DIST = \
- test-decode.h \
test-subpicture-data.h \
$(test_utils_source_h) \
- $(test_codecs_source_c) \
- $(test_codecs_source_h) \
$(NULL)
# Extra clean files so that maintainer-clean removes *everything*