summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorgb <gb@5584edef-b1fe-4b99-b61b-dd2bab72e969>2010-03-16 08:49:16 +0000
committergb <gb@5584edef-b1fe-4b99-b61b-dd2bab72e969>2010-03-16 08:49:16 +0000
commit148d104c1ab634d634a2131d3d1c33357dd1a795 (patch)
tree0373b3d18103928cbfc1faf3a01db0f62b795ab5 /tests/Makefile.am
parent69d58a0857f1a4c3483cf91224185199290d82ef (diff)
downloadgst-vaapi-148d104c1ab634d634a2131d3d1c33357dd1a795.tar.gz
Move tests to top-level tests/ directory.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am27
1 files changed, 26 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index cbf577e6..cc7cdcf6 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,4 +1,29 @@
-SUBDIRS = examples
+noinst_PROGRAMS = \
+ test-display \
+ test-surfaces \
+ test-windows \
+ $(NULL)
+
+TEST_CFLAGS = \
+ $(GST_CFLAGS) \
+ -I$(top_srcdir)/gst-libs \
+ $(X11_CFLAGS)
+
+TEST_LIBS = \
+ $(top_builddir)/gst-libs/gst/vaapi/libgstvaapi-@GST_MAJORMINOR@.la \
+ $(X11_LIBS)
+
+test_display_SOURCES = test-display.c
+test_display_CFLAGS = $(TEST_CFLAGS)
+test_display_LDADD = $(TEST_LIBS)
+
+test_surfaces_SOURCES = test-surfaces.c
+test_surfaces_CFLAGS = $(TEST_CFLAGS)
+test_surfaces_LDADD = $(TEST_LIBS)
+
+test_windows_SOURCES = test-windows.c
+test_windows_CFLAGS = $(TEST_CFLAGS)
+test_windows_LDADD = $(TEST_LIBS)
# Extra clean files so that maintainer-clean removes *everything*
MAINTAINERCLEANFILES = Makefile.in