summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorGwenole Beauchesne <gwenole.beauchesne@intel.com>2012-08-01 15:44:49 +0200
committerGwenole Beauchesne <gwenole.beauchesne@intel.com>2012-08-01 16:40:17 +0200
commit34a2b33c1ab9643cf81209ada648c64cd1e02b0f (patch)
tree75e88996535906c1680a5815b60ae681bc0e4b1b /tests/Makefile.am
parent657f0a4a6f76e121043d022c0f8be1cfdb4834d9 (diff)
downloadgst-vaapi-34a2b33c1ab9643cf81209ada648c64cd1e02b0f.tar.gz
tests: add support for headless decoding.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 1aacdc99..4c8edbbc 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -24,6 +24,13 @@ TEST_LIBS = \
$(GST_LIBS) \
$(top_builddir)/gst-libs/gst/vaapi/libgstvaapi-@GST_MAJORMINOR@.la
+if USE_DRM
+TEST_CFLAGS += $(LIBVA_DRM_CFLAGS)
+TEST_LIBS += \
+ $(LIBVA_DRM_LIBS) \
+ $(top_builddir)/gst-libs/gst/vaapi/libgstvaapi-drm-@GST_MAJORMINOR@.la
+endif
+
if USE_X11
TEST_CFLAGS += $(X11_CFLAGS)
TEST_LIBS += \