summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorGwenole Beauchesne <gwenole.beauchesne@intel.com>2012-07-20 15:57:26 +0200
committerGwenole Beauchesne <gwenole.beauchesne@intel.com>2012-07-20 15:59:14 +0200
commit67fad5a27e10029bff85c206b8659be7b52ea063 (patch)
tree86e2271350212febd1c82d1989374a7fc14fd8fd /tests/Makefile.am
parentb6c97e31ee5a306cf4b11dcce8619e441686072a (diff)
downloadgst-vaapi-67fad5a27e10029bff85c206b8659be7b52ea063.tar.gz
configure: fix previous commit for GLX deps.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index e45b72f3..ff1e09c7 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -14,7 +14,7 @@ endif
TEST_CFLAGS = $(LIBVA_CFLAGS) -I$(top_srcdir)/gst-libs $(GST_CFLAGS) -DGST_USE_UNSTABLE_API
TEST_X11_CFLAGS = -DUSE_X11 $(X11_CFLAGS)
-TEST_GLX_CFLAGS = -DUSE_GLX $(GLX_CFLAGS)
+TEST_GLX_CFLAGS = -DUSE_GLX $(X11_CFLAGS) $(GL_CFLAGS)
TEST_MIX_CFLAGS = $(TEST_X11_CFLAGS)
if USE_GLX
TEST_MIX_CFLAGS += $(TEST_GLX_CFLAGS)
@@ -31,7 +31,8 @@ TEST_X11_LIBS = \
$(top_builddir)/gst-libs/gst/vaapi/libgstvaapi-x11-@GST_MAJORMINOR@.la
TEST_GLX_LIBS = \
- $(GLX_LIBS) \
+ $(X11_LIBS) \
+ $(GL_LIBS) \
$(GST_LIBS) \
$(LIBVA_GLX_LIBS) \
$(top_builddir)/gst-libs/gst/vaapi/libgstvaapi-glx-@GST_MAJORMINOR@.la