summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorGwenole Beauchesne <gwenole.beauchesne@intel.com>2014-12-01 14:52:39 +0100
committerGwenole Beauchesne <gwenole.beauchesne@intel.com>2015-02-24 15:20:03 +0100
commit8d4498f9fdd7d901f0292546e638384286ee02cd (patch)
tree33bc3a5af4ef2526fc9982648011030374c7127d /tests/Makefile.am
parentaabb8c99c23199ee17c4a91b64573c2cc5fe619c (diff)
downloadgst-vaapi-8d4498f9fdd7d901f0292546e638384286ee02cd.tar.gz
egl: update tests.
Add initial support for EGL to tests. The new EGL backend can be selected through the --egl command line option. The OpenGL|ES version can further be selected with the --gles-version command line option, where the default of 0 means "desktop" OpenGL.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index ec6863a6..80826d1a 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -52,6 +52,14 @@ TEST_LIBS += \
$(top_builddir)/gst-libs/gst/vaapi/libgstvaapi-glx-$(GST_API_VERSION).la
endif
+if USE_EGL
+TEST_CFLAGS += $(EGL_CFLAGS)
+TEST_LIBS += \
+ $(LIBVA_EGL_LIBS) \
+ $(EGL_LIBS) \
+ $(top_builddir)/gst-libs/gst/vaapi/libgstvaapi-egl-$(GST_API_VERSION).la
+endif
+
if USE_WAYLAND
TEST_CFLAGS += $(WAYLAND_CFLAGS)
TEST_LIBS += \