summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorThibault Saunier <thibault.saunier@collabora.com>2011-10-14 13:00:12 -0300
committerGwenole Beauchesne <gwenole.beauchesne@intel.com>2011-12-12 15:08:42 +0100
commitbb72c5555586ef0cf148cb353936f2f28024fd40 (patch)
tree5a1d88d45270c153883aa4aefd7370c740c8882b /tests/Makefile.am
parentcbf81d7d51db8acb7d788263578fa58906d9ac92 (diff)
downloadgst-vaapi-bb72c5555586ef0cf148cb353936f2f28024fd40.tar.gz
tests: add test for subpictures.
Signed-off-by: Gwenole Beauchesne <gwenole.beauchesne@intel.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 8a273055..d1c7d458 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -3,6 +3,7 @@ noinst_PROGRAMS = \
test-display \
test-surfaces \
test-windows \
+ test-subpicture \
$(NULL)
if USE_GLX
@@ -55,6 +56,10 @@ test_surfaces_SOURCES = test-surfaces.c
test_surfaces_CFLAGS = $(TEST_CFLAGS) $(TEST_X11_CFLAGS)
test_surfaces_LDADD = $(TEST_LIBS) $(TEST_X11_LIBS)
+test_subpicture_SOURCES = test-subpicture.c test-h264.c test-subpicture-data.c
+test_subpicture_CFLAGS = $(TEST_CFLAGS) $(TEST_X11_CFLAGS)
+test_subpicture_LDADD = $(TEST_LIBS) $(TEST_X11_LIBS)
+
test_windows_SOURCES = test-windows.c image.c
test_windows_CFLAGS = $(TEST_CFLAGS) $(TEST_X11_CFLAGS)
test_windows_LDADD = $(TEST_LIBS) $(TEST_X11_LIBS)