summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorVíctor Manuel Jáquez Leal <victorx.jaquez@intel.com>2015-05-05 13:08:25 +0200
committerVíctor Manuel Jáquez Leal <victorx.jaquez@intel.com>2015-05-12 11:24:41 +0200
commitbe40a1d479794539bc335ecba45b3a012489eecf (patch)
treecef21aefcef350825ce6f4934100a82acd2c0260 /tests/Makefile.am
parent069edff757d92e37cce0ec1411a9821cc9df2ace (diff)
downloadgst-vaapi-be40a1d479794539bc335ecba45b3a012489eecf.tar.gz
tests: add simple-encoder program
This patch adds a simple-encoder test program that uses libgstvaapi for video encoding to elementary (raw) streams. Input stream is raw YUV in the Y4M format. That can be from a regular file or standard input when the input filename is "-". Usage: simple-encoder [options]* <source> Options: --output|-o output file name --codec|-c codec to use for video encoding --bitrate|-b desired bitrate (kbps) By default, and as an initial patch, the encoded stream shall conform to the minimally supported profile. That is "Constrained Baseline Profile" for H.264 and "Simple Profile" for MPEG-2. Though, those are the defaults to be generated by libgstvaapi. You can find Y4M sample files here http://samples.mplayerhq.hu/yuv4mpeg2/ Original-patch-by: Changzhi Wei <changzhix.wei@intel.com> * general code clean-up * removed the yuv reader thread * re-wrote the y4m file parser * updated used API fixed some wrong usage * fixed a lot of memory leaks * added the bitrate setting * keep fps' numerator and denominator * simplified the thread control * removed custom logging and use glib Signed-off-by: Víctor Manuel Jáquez Leal <victorx.jaquez@intel.com> https://bugzilla.gnome.org/show_bug.cgi?id=719528
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 9b016813..fa1ee3a4 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -6,6 +6,7 @@ noinst_PROGRAMS = \
test-surfaces \
test-windows \
test-subpicture \
+ simple-encoder \
$(NULL)
if USE_GLX
@@ -122,6 +123,12 @@ simple_decoder_SOURCES = $(simple_decoder_source_c)
simple_decoder_CFLAGS = $(TEST_CFLAGS) $(GST_VIDEO_CFLAGS)
simple_decoder_LDADD = libutils.la $(TEST_LIBS) $(GST_VIDEO_LIBS)
+simple_encoder_source_c = simple-encoder.c y4mreader.c
+simple_encoder_source_h = y4mreader.h
+simple_encoder_SOURCES = $(simple_encoder_source_c)
+simple_encoder_CFLAGS = $(TEST_CFLAGS) $(GST_VIDEO_CFLAGS)
+simple_encoder_LDADD = libutils.la $(TEST_LIBS) $(GST_VIDEO_LIBS)
+
EXTRA_DIST = \
test-subpicture-data.h \
$(simple_decoder_source_h) \