summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorGwenole Beauchesne <gwenole.beauchesne@intel.com>2013-01-15 17:33:18 +0100
committerGwenole Beauchesne <gwenole.beauchesne@intel.com>2013-01-17 19:03:41 +0100
commitc094fe303849a384d6761c512c235e1e04a33a2d (patch)
treee4214fd6fb170502a68bb2288a0e5dc655b735da /tests/Makefile.am
parentb22bade3106d097ce767befb46b9786e095e7497 (diff)
downloadgst-vaapi-c094fe303849a384d6761c512c235e1e04a33a2d.tar.gz
tests: add simple decoder application.
Add simple decoder application to show off decoding capabilities from raw bitstreams, for debugging or performance evaluation purposes.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 83d1e773..dbba30ef 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,4 +1,5 @@
noinst_PROGRAMS = \
+ simple-decoder \
test-decode \
test-display \
test-surfaces \
@@ -101,8 +102,15 @@ test_textures_SOURCES = test-textures.c
test_textures_CFLAGS = $(TEST_CFLAGS)
test_textures_LDADD = libutils.la $(TEST_LIBS)
+simple_decoder_source_c = simple-decoder.c
+simple_decoder_source_h =
+simple_decoder_SOURCES = $(simple_decoder_source_c)
+simple_decoder_CFLAGS = $(TEST_CFLAGS)
+simple_decoder_LDADD = libutils.la $(TEST_LIBS)
+
EXTRA_DIST = \
test-subpicture-data.h \
+ $(simple_decoder_source_h) \
$(test_utils_dec_source_h) \
$(test_utils_source_h) \
$(NULL)