summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorGwenole Beauchesne <gwenole.beauchesne@intel.com>2013-01-10 11:22:38 +0100
committerGwenole Beauchesne <gwenole.beauchesne@intel.com>2013-01-11 15:32:17 +0100
commitd9111eeaf5af485c2ea7b23c0b0c3385e46a623e (patch)
tree3ee74315663497d13cdcf73f0c79f72a93b002d4 /tests/Makefile.am
parent7e1a8eabfeaa4e7ca7f3998881d5b35d23a2b64f (diff)
downloadgst-vaapi-d9111eeaf5af485c2ea7b23c0b0c3385e46a623e.tar.gz
tests: add decoder helpers.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am22
1 files changed, 13 insertions, 9 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index fc258eed..afe894db 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -57,25 +57,28 @@ TEST_LIBS += \
$(top_builddir)/gst-libs/gst/vaapi/libgstvaapi-wayland-@GST_MAJORMINOR@.la
endif
-test_codecs_source_c = \
+test_utils_dec_source_c = \
+ decoder.c \
test-h264.c \
test-jpeg.c \
test-mpeg2.c \
test-mpeg4.c \
test-vc1.c \
$(NULL)
-test_codecs_source_h = $(test_codecs_source_c:%.c=%.h) test-decode.h
+test_utils_dec_source_h = $(test_utils_dec_source_c:%.c=%.h) test-decode.h
-test_utils_source_c = image.c output.c $(test_codecs_source_c)
-test_utils_source_h = image.h output.h $(test_codecs_source_h)
+test_utils_source_c = image.c output.c
+test_utils_source_h = image.h output.h
-noinst_LTLIBRARIES = libutils.la
+noinst_LTLIBRARIES = libutils.la libutils_dec.la
libutils_la_SOURCES = $(test_utils_source_c)
libutils_la_CFLAGS = $(TEST_CFLAGS)
+libutils_dec_la_SOURCES = $(test_utils_dec_source_c)
+libutils_dec_la_CFLAGS = $(TEST_CFLAGS)
-test_decode_SOURCES = test-decode.c $(test_codecs_source_c)
+test_decode_SOURCES = test-decode.c
test_decode_CFLAGS = $(TEST_CFLAGS)
-test_decode_LDADD = libutils.la $(TEST_LIBS)
+test_decode_LDADD = libutils.la libutils_dec.la $(TEST_LIBS)
test_display_SOURCES = test-display.c
test_display_CFLAGS = $(TEST_CFLAGS)
@@ -98,8 +101,9 @@ test_textures_CFLAGS = $(TEST_CFLAGS)
test_textures_LDADD = libutils.la $(TEST_LIBS)
EXTRA_DIST = \
- test-subpicture-data.h \
- $(test_utils_source_h) \
+ test-subpicture-data.h \
+ $(test_utils_dec_source_h) \
+ $(test_utils_source_h) \
$(NULL)
# Extra clean files so that maintainer-clean removes *everything*