summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am32
1 files changed, 24 insertions, 8 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 3637d922..831a9d91 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -29,49 +29,53 @@ TEST_CFLAGS = \
$(GST_VIDEO_CFLAGS) \
$(NULL)
+GST_VAAPI_LIBS = $(top_builddir)/gst-libs/gst/vaapi/libgstvaapi-$(GST_API_VERSION).la
TEST_LIBS = \
$(LIBVA_LIBS) \
$(GST_LIBS) \
- $(top_builddir)/gst-libs/gst/vaapi/libgstvaapi-$(GST_API_VERSION).la
+ $(NULL)
if USE_DRM
+GST_VAAPI_LIBS += $(top_builddir)/gst-libs/gst/vaapi/libgstvaapi-drm-$(GST_API_VERSION).la
TEST_CFLAGS += $(LIBVA_DRM_CFLAGS)
-TEST_LIBS += \
- $(LIBVA_DRM_LIBS) \
- $(top_builddir)/gst-libs/gst/vaapi/libgstvaapi-drm-$(GST_API_VERSION).la
+TEST_LIBS += $(LIBVA_DRM_LIBS)
endif
if USE_X11
+GST_VAAPI_LIBS += $(top_builddir)/gst-libs/gst/vaapi/libgstvaapi-x11-$(GST_API_VERSION).la
TEST_CFLAGS += $(X11_CFLAGS)
TEST_LIBS += \
$(LIBVA_X11_LIBS) \
$(X11_LIBS) \
- $(top_builddir)/gst-libs/gst/vaapi/libgstvaapi-x11-$(GST_API_VERSION).la
+ $(NULL)
endif
if USE_GLX
+GST_VAAPI_LIBS += $(top_builddir)/gst-libs/gst/vaapi/libgstvaapi-glx-$(GST_API_VERSION).la
TEST_CFLAGS += $(X11_CFLAGS) $(GL_CFLAGS)
TEST_LIBS += \
$(LIBVA_GLX_LIBS) \
$(X11_LIBS) \
$(GL_LIBS) \
- $(top_builddir)/gst-libs/gst/vaapi/libgstvaapi-glx-$(GST_API_VERSION).la
+ $(NULL)
endif
if USE_EGL
+GST_VAAPI_LIBS += $(top_builddir)/gst-libs/gst/vaapi/libgstvaapi-egl-$(GST_API_VERSION).la
TEST_CFLAGS += $(EGL_CFLAGS)
TEST_LIBS += \
$(LIBVA_EGL_LIBS) \
$(EGL_LIBS) \
- $(top_builddir)/gst-libs/gst/vaapi/libgstvaapi-egl-$(GST_API_VERSION).la
+ $(NULL)
endif
if USE_WAYLAND
+GST_VAAPI_LIBS += $(top_builddir)/gst-libs/gst/vaapi/libgstvaapi-wayland-$(GST_API_VERSION).la
TEST_CFLAGS += $(WAYLAND_CFLAGS)
TEST_LIBS += \
$(LIBVA_WAYLAND_LIBS) \
$(WAYLAND_LIBS) \
- $(top_builddir)/gst-libs/gst/vaapi/libgstvaapi-wayland-$(GST_API_VERSION).la
+ $(NULL)
endif
test_utils_dec_source_c = \
@@ -88,10 +92,14 @@ test_utils_source_c = codec.c image.c output.c
test_utils_source_h = codec.h image.h output.h
noinst_LTLIBRARIES = libutils.la libutils_dec.la
+
libutils_la_SOURCES = $(test_utils_source_c)
libutils_la_CFLAGS = $(TEST_CFLAGS)
+libutils_la_LDFLAGS = $(GST_VAAPI_LIBS)
+
libutils_dec_la_SOURCES = $(test_utils_dec_source_c)
libutils_dec_la_CFLAGS = $(TEST_CFLAGS)
+libutils_dec_la_LDFLAGS = $(GST_VAAPI_LIBS)
test_decode_SOURCES = test-decode.c
test_decode_CFLAGS = $(TEST_CFLAGS)
@@ -99,39 +107,47 @@ test_decode_LDADD = libutils.la libutils_dec.la $(TEST_LIBS)
test_display_SOURCES = test-display.c
test_display_CFLAGS = $(TEST_CFLAGS)
+test_display_LDFLAGS = $(GST_VAAPI_LIBS)
test_display_LDADD = libutils.la $(TEST_LIBS)
test_filter_SOURCES = test-filter.c
test_filter_CFLAGS = $(TEST_CFLAGS)
+test_filter_LDFLAGS = $(GST_VAAPI_LIBS)
test_filter_LDADD = libutils.la $(TEST_LIBS) $(GST_VIDEO_LIBS)
test_surfaces_SOURCES = test-surfaces.c
test_surfaces_CFLAGS = $(TEST_CFLAGS) $(GST_VIDEO_CFLAGS)
+test_surfaces_LDFLAGS = $(GST_VAAPI_LIBS)
test_surfaces_LDADD = libutils.la $(TEST_LIBS) $(GST_VIDEO_LIBS)
test_subpicture_SOURCES = test-subpicture.c test-subpicture-data.c
test_subpicture_CFLAGS = $(TEST_CFLAGS) $(GST_VIDEO_CFLAGS)
test_subpicture_LDADD = libutils.la libutils_dec.la $(TEST_LIBS) \
$(GST_VIDEO_LIBS)
+test_subpicture_LDFLAGS = $(GST_VAAPI_LIBS)
test_windows_SOURCES = test-windows.c
test_windows_CFLAGS = $(TEST_CFLAGS)
+test_windows_LDFLAGS = $(GST_VAAPI_LIBS)
test_windows_LDADD = libutils.la $(TEST_LIBS)
test_textures_SOURCES = test-textures.c
test_textures_CFLAGS = $(TEST_CFLAGS)
+test_textures_LDFLAGS = $(GST_VAAPI_LIBS)
test_textures_LDADD = libutils.la $(TEST_LIBS)
simple_decoder_source_c = simple-decoder.c
simple_decoder_source_h =
simple_decoder_SOURCES = $(simple_decoder_source_c)
simple_decoder_CFLAGS = $(TEST_CFLAGS) $(GST_VIDEO_CFLAGS)
+simple_decoder_LDFLAGS = $(GST_VAAPI_LIBS)
simple_decoder_LDADD = libutils.la $(TEST_LIBS) $(GST_VIDEO_LIBS)
simple_encoder_source_c = simple-encoder.c y4mreader.c
simple_encoder_source_h = y4mreader.h
simple_encoder_SOURCES = $(simple_encoder_source_c)
simple_encoder_CFLAGS = $(TEST_CFLAGS) $(GST_VIDEO_CFLAGS)
+simple_encoder_LDFLAGS = $(GST_VAAPI_LIBS)
simple_encoder_LDADD = libutils.la $(TEST_LIBS) $(GST_VIDEO_LIBS)
EXTRA_DIST = \