summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Waters <matthew@centricular.com>2015-09-02 23:45:07 +1000
committerMatthew Waters <matthew@centricular.com>2015-09-28 16:47:00 +1000
commit18d5ed0408a9ae66f2a5f508941c09de5afe01ae (patch)
tree9ee3874cdc73701a8e69fc83951f2f9e87c418c8 /configure.ac
parentf12caa5c2255493d42f5e5aa14b98a9b0a99a66b (diff)
downloadgstreamer-plugins-bad-18d5ed0408a9ae66f2a5f508941c09de5afe01ae.tar.gz
qt: add support for building/running on android
Including: - Necessary configure checks - Necessary compile time platform checks - Necessary runtime qt android platform detection - Escaping GLsync definition with Qt's GLES2 implementation https://bugzilla.gnome.org/show_bug.cgi?id=754466
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 40cdd4700..c8d3f810b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2680,6 +2680,25 @@ AG_GST_CHECK_FEATURE(QT, [Qt elements], qt, [
HAVE_QT_WINDOWING="yes"
], [AC_MSG_NOTICE([Could not find Qt Wayland integration])])
fi
+ if test "x$GST_GL_HAVE_WINDOW_ANDROID" = "x1" -a "x$GST_GL_HAVE_PLATFORM_EGL" = "x1"; then
+ PKG_CHECK_MODULES(QT_ANDROID, Qt5AndroidExtras, [
+ # c++ on android requires a standard library and there are multiple
+ # choices. cerbero provides a pkg-config file the describes a choice
+ # so try to use that. Outside cerbero one has to pass these flags
+ # manually for the library one is using
+ PKG_CHECK_MODULES(GNUSTL, gnustl, [
+ QT_CFLAGS="$QT_CFLAGS $GNUSTL_CFLAGS"
+ QT_LIBS="$QT_CFLAGS $GNUSTL_LIBS"
+ ], [
+ AC_MSG_NOTICE([Could not find Standard C++ library])])
+
+ AC_DEFINE([HAVE_QT_ANDROID], [],
+ [Define if Qt Android integration is installed])
+ QT_CFLAGS="$QT_CFLAGS $QT_ANDROID_CFLAGS"
+ QT_LIBS="$QT_LIBS $QT_ANDROID_LIBS"
+ HAVE_QT_WINDOWING="yes"
+ ], [AC_MSG_NOTICE([Could not find Qt Android integration])])
+ fi
if test "x$HAVE_QT_WINDOWING" = "xno"; then
AC_MSG_WARN([Could not find any Qt Windowing integration])
HAVE_QT="no"