summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2015-07-10 19:05:41 +0100
committerTim-Philipp Müller <tim@centricular.com>2015-07-10 19:07:42 +0100
commit1a59af2e7ebcc6bd2aff28d2baea3fc83ec0fd0f (patch)
tree2a81394de5b3ee4b25ea2cab769ee09852ad073d /configure.ac
parent7cb734b1cd2809a301c5a58a664d61ab4347d0a6 (diff)
downloadgstreamer-plugins-bad-1a59af2e7ebcc6bd2aff28d2baea3fc83ec0fd0f.tar.gz
configure: try harder to find the right Qt5 build tools
First check for Qt build tools in the host_bins directory from the Qt5Core pkg-config file. This fixes the situation where both Qt4 and Qt5 are installed but the global moc/uic/etc. are the Qt4 version, which would result in build failures.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index ce6f57297..2cb967ba0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2606,9 +2606,11 @@ dnl *** Qt ***
translit(dnm, m, l) AM_CONDITIONAL(USE_QT, true)
AG_GST_CHECK_FEATURE(QT, [Qt elements], qt, [
PKG_CHECK_MODULES(QT, Qt5Core Qt5Gui Qt5Quick, [
- AC_CHECK_PROGS(MOC, [moc-qt5 moc])
- AC_CHECK_PROGS(UIC, [uic-qt5 uic])
- AC_CHECK_PROGS(RCC, [rcc])
+ QT_PATH=`$PKG_CONFIG --variable=exec_prefix Qt5Core`
+ QT_HOST_PATH=`$PKG_CONFIG --variable=host_bins Qt5Core`
+ AC_PATH_PROGS(MOC, [moc-qt5 moc], moc, ["${QT_HOST_PATH}" "${QT_PATH}/bin"])
+ AC_PATH_PROGS(RCC, [rcc-qt5 rcc], rcc, ["${QT_HOST_PATH}" "${QT_PATH}/bin"])
+ AC_PATH_PROGS(UIC, [uic-qt5 uic], uic, ["${QT_HOST_PATH}" "${QT_PATH}/bin"])
if test "x$MOC" = "x" || test "x$UIC" = "x" || test "x$RCC" = "x"; then
AC_MSG_WARN([One of the required qt build programs was not found])
HAVE_QT="no"