summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2014-12-12 20:57:28 +0000
committerTim-Philipp Müller <tim@centricular.com>2014-12-12 20:58:49 +0000
commit329f0ccba1aa604da1bd80293fd1fe717447df5d (patch)
treef622c814d4b30990b8145412eeda567f4a0633ff /configure.ac
parent15394aa70543f55c54fa8a474805224f4138f76c (diff)
downloadgstreamer-plugins-bad-329f0ccba1aa604da1bd80293fd1fe717447df5d.tar.gz
Revert "openh264: fix to work with released versions and master of upstream"
This reverts commit 15394aa70543f55c54fa8a474805224f4138f76c. The latest release (v1.1) does not have pkg-config support yet, so this plugin won't be built with the latest release. Cerbero uses the latest release, so this makes cerbero builds fail, which expect the plugin to be built. We can re-commit this once there's a release that includes pkg-config support.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 21 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 71ca13c27..fd1ad0321 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2521,7 +2521,27 @@ AG_GST_CHECK_FEATURE(OPENEXR, [openexr library], openexr, [
dnl *** openh264 ***
translit(dnm, m, l) AM_CONDITIONAL(USE_OPENH264, true)
AG_GST_CHECK_FEATURE(OPENH264, [openh264 library], openh264, [
- AG_GST_PKG_CHECK_MODULES(OPENH264, openh264)
+ AC_LANG_PUSH([C++])
+ AG_GST_CHECK_LIBHEADER(OPENH264, openh264, WelsSnprintf, $PTHREAD_LIBS,
+ wels/codec_api.h, [
+ AC_MSG_CHECKING([for right openh264 version/snapshot])
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <wels/codec_app_def.h>
+#include <wels/codec_api.h>]], [[
+ SFrameBSInfo frame_info;
+ SEncParamExt enc_params;
+ enc_params.iInputCsp = videoFormatI420;
+ int *p = (int *) &frame_info.eFrameType;
+ *p = RC_LOW_BW_MODE;
+ ]])], [
+ AC_MSG_RESULT(yes)
+ OPENH264_LIBS="-lopenh264 $PTHREAD_LIBS"
+ ], [
+ AC_MSG_RESULT(no)
+ HAVE_OPENH264="no"
+ ])
+ ])
+ AC_LANG_POP([C++])
+ AC_SUBST(OPENH264_LIBS)
])
dnl *** OpenJPEG ***