summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2016-12-16 19:15:36 +0000
committerTim-Philipp Müller <tim@centricular.com>2016-12-16 19:16:10 +0000
commit936995ba8db1d36e4cfec8ca24e81258125539cc (patch)
tree4323565c10c8d698d6372ebd83fa2f27634cf2d6 /configure.ac
parentebe8ff3ac15c825902eb7357759d2f2b211f4426 (diff)
downloadgstreamer-plugins-bad-936995ba8db1d36e4cfec8ca24e81258125539cc.tar.gz
win32: remove generation of pre-made config.h for msvc builds
This is no longer needed with the Meson build.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac39
1 files changed, 0 insertions, 39 deletions
diff --git a/configure.ac b/configure.ac
index 8feaf0ad6..10bdca764 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3934,45 +3934,6 @@ tools/Makefile
m4/Makefile
)
-dnl Create the config.h file for Visual Studio builds
-dnl Beware of spaces and /'s in some of the shell variable contents.
-sed \
- -e 's/.*config.h.in.*autoheader.*/\/* Autogenerated config.h created for win32 Visual Studio builds *\/\n\n\/* PREFIX -- specifically added for Windows for easier moving *\/\n#define PREFIX "C:\\\\gstreamer"/' \
- -e 's/.* GETTEXT_PACKAGE$/#define GETTEXT_PACKAGE "'$GETTEXT_PACKAGE'"/' \
- -e 's/.* GST_DATADIR$/#define GST_DATADIR PREFIX "\\\\share"/' \
- -e 's/.* GST_LEVEL_DEFAULT$/#define GST_LEVEL_DEFAULT GST_LEVEL_ERROR/' \
- -e 's/.* GST_LICENSE$/#define GST_LICENSE "'$GST_LICENSE'"/' \
- -e 's/.* GST_API_VERSION$/#define GST_API_VERSION "'$GST_API_VERSION'"/' \
- -e "s,.* GST_PACKAGE_NAME$,#define GST_PACKAGE_NAME \"${GST_PACKAGE_NAME}\"," \
- -e 's/.* GST_PACKAGE_ORIGIN$/#define GST_PACKAGE_ORIGIN "Unknown package origin"/' \
- -e "s,.* GST_PACKAGE_RELEASE_DATETIME$,#define GST_PACKAGE_RELEASE_DATETIME \"${GST_PACKAGE_RELEASE_DATETIME}\"," \
- -e 's/.* HAVE_CPU_I386$/#define HAVE_CPU_I386 1/' \
- -e 's/.* HAVE_STDLIB_H$/#define HAVE_STDLIB_H 1/' \
- -e 's/.* HAVE_STRING_H$/#define HAVE_STRING_H 1/' \
- -e 's/.* HAVE_SYS_STAT_H$/#define HAVE_SYS_STAT_H 1/' \
- -e 's/.* HAVE_SYS_TYPES_H$/#define HAVE_SYS_TYPES_H 1/' \
- -e 's/.* HAVE_WIN32$/#define HAVE_WIN32 1/' \
- -e 's/.* HOST_CPU$/#define HOST_CPU "i686"/' \
- -e 's/.* LIBDIR$/#ifdef _DEBUG\n# define LIBDIR PREFIX "\\\\debug\\\\lib"\n#else\n# define LIBDIR PREFIX "\\\\lib"\n#endif/' \
- -e 's/.* LOCALEDIR$/#define LOCALEDIR PREFIX "\\\\share\\\\locale"/' \
- -e "s/.* PACKAGE$/#define PACKAGE \"$PACKAGE\"/" \
- -e 's/.* PACKAGE_BUGREPORT$/#define PACKAGE_BUGREPORT "http:\/\/bugzilla.gnome.org\/enter_bug.cgi?product=GStreamer"/' \
- -e "s/.* PACKAGE_NAME$/#define PACKAGE_NAME \"$PACKAGE_NAME\"/" \
- -e "s/.* PACKAGE_STRING$/#define PACKAGE_STRING \"$PACKAGE_STRING\"/" \
- -e 's/.* PACKAGE_TARNAME$/#define PACKAGE_TARNAME "'$PACKAGE_TARNAME'"/' \
- -e 's/.* PACKAGE_VERSION$/#define PACKAGE_VERSION "'$PACKAGE_VERSION'"/' \
- -e 's/.* PLUGINDIR$/#ifdef _DEBUG\n# define PLUGINDIR PREFIX "\\\\debug\\\\lib\\\\gstreamer-0.11"\n#else\n# define PLUGINDIR PREFIX "\\\\lib\\\\gstreamer-0.11"\n#endif/' \
- -e 's/.* VERSION$/#define VERSION "'$VERSION'"/' \
- -e "s/.* DEFAULT_AUDIOSINK$/#define DEFAULT_AUDIOSINK \"directsoundsink\"/" \
- -e "s/.* DEFAULT_AUDIOSRC$/#define DEFAULT_AUDIOSRC \"audiotestsrc\"/" \
- -e "s/.* DEFAULT_VIDEOSRC$/#define DEFAULT_VIDEOSRC \"videotestsrc\"/" \
- -e "s/.* DEFAULT_VISUALIZER$/#define DEFAULT_VISUALIZER \"goom\"/" \
- -e 's/.* HAVE_WINDOWS_H$/#define HAVE_WINDOWS_H 1/' \
- -e 's/.* HAVE_WININET_H$/#define HAVE_WININET_H 1/' \
- -e 's/.* HAVE_WINSOCK2_H$/#define HAVE_WINSOCK2_H 1/' \
- -e 's/.* HAVE_WS2TCPIP_H$/#define HAVE_WS2TCPIP_H 1/' \
- config.h.in >win32/common/config.h-new
-
AC_OUTPUT
AG_GST_OUTPUT_PLUGINS