summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorZaheer Abbas Merali <zaheerabbas@merali.org>2005-05-09 20:09:44 +0000
committerZaheer Abbas Merali <zaheerabbas@merali.org>2005-05-09 20:09:44 +0000
commit9a629cf2240d415c86eb529cb5ddaf6630d494a7 (patch)
tree78478236ad4911ef87c4fdaec23b47b14f773cc0 /configure.ac
parent943bb6034d04128af2d0990b2fceef6715363292 (diff)
downloadgstreamer-plugins-bad-9a629cf2240d415c86eb529cb5ddaf6630d494a7.tar.gz
Port shout2 plugin
Original commit message from CVS: 2005-05-09 Zaheer Abbas Merali <zaheerabbas at merali dot org> * PORTED_09: * configure.ac: * ext/Makefile.am: * ext/shout2/Makefile.am: * ext/shout2/gstshout2.c: (gst_shout2send_get_type), (gst_shout2send_base_init), (gst_shout2send_class_init), (gst_shout2send_init), (gst_shout2send_event), (gst_shout2send_render), (gst_shout2send_set_property), (gst_shout2send_get_property), (gst_shout2send_setcaps), (gst_shout2send_change_state): * ext/shout2/gstshout2.h: Port shout2 plugin
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0616b1b05..81efea0b7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -380,6 +380,20 @@ GST_CHECK_FEATURE(LIBCACA, [libcaca], libcaca, [
AC_SUBST(LIBCACA_LIBS)
])
+dnl *** shout2 ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_SHOUT2, true)
+GST_CHECK_FEATURE(SHOUT2, [shout2 plug-in], shout2send, [
+ PKG_CHECK_MODULES(SHOUT2, shout >= 2.0, [
+ HAVE_SHOUT2="yes"
+ AC_SUBST(SHOUT2_CFLAGS)
+ AC_SUBST(SHOUT2_LIBS)
+ ], [
+ AM_PATH_SHOUT2(HAVE_SHOUT2="yes", HAVE_SHOUT2="no")
+ AC_SUBST(SHOUT2_CFLAGS)
+ AC_SUBST(SHOUT2_LIBS)
+ ])
+])
+
dnl *** sidplay : works with libsidplay 1.36.x (not 2.x.x) ***
translit(dnm, m, l) AM_CONDITIONAL(USE_SIDPLAY, true)
GST_CHECK_FEATURE(SIDPLAY, [sidplay plug-in], sidplay, [
@@ -468,6 +482,7 @@ ext/Makefile
ext/aalib/Makefile
ext/libcaca/Makefile
ext/mad/Makefile
+ext/shout2/Makefile
ext/sidplay/Makefile
common/Makefile
common/m4/Makefile