summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVincent Abriou <vincent.abriou@st.com>2014-10-29 10:09:35 +0100
committerMatthew Waters <matthew@centricular.com>2014-10-29 22:40:42 +1100
commit9f69bcbfe5ccca672c2042beafda94d37e677148 (patch)
tree86eea3193341269a930f35da8fd6e7126a936104 /configure.ac
parent916b954315abc2f94348ec0be3e116c19b080b54 (diff)
downloadgstreamer-plugins-bad-9f69bcbfe5ccca672c2042beafda94d37e677148.tar.gz
configure.ac: auto decision to include GL library fails
The part of the configure.ac that consist to check if we can include both GL and GLES2 at the same time is failing. Indeed, in the case NEED_GLES2=yes and NEED_OPENGL=auto, HAVE_OPENGL variable is updated whereas it should be HAVE_GL variable that has to be updated (HAVE_OPENGL variable is not used in the rest of the configure.ac). https://bugzilla.gnome.org/show_bug.cgi?id=739348 Signed-off-by: Vincent Abriou <vincent.abriou@st.com> Reviewed-by: Benjamin GAIGNARD <benjamin.gaignard@linaro.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 85c693ae0..150ccaa92 100644
--- a/configure.ac
+++ b/configure.ac
@@ -886,7 +886,7 @@ if test "x$HAVE_GL" = "xyes" -a "x$HAVE_GLU" = "xyes" -a "x$HAVE_GLES2" = "xyes"
AC_MSG_ERROR([Cannot seem to include both GL and GLES2 headers. Try disabling one API])
fi
AC_MSG_WARN([Disabling Desktop GL support])
- HAVE_OPENGL=no
+ HAVE_GL=no
else
AC_MSG_WARN([Disabling GL|ES 2.0 support])
HAVE_GLES2=no