summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMark Nauwelaerts <mark.nauwelaerts@collabora.co.uk>2008-08-11 15:16:14 +0000
committerMark Nauwelaerts <mark.nauwelaerts@collabora.co.uk>2008-08-11 15:16:14 +0000
commitdbfc737cd24f6d03e6488e4d2db2ec8114821138 (patch)
treef955e6ad4ccbbc66976f07c1fbe39cb5a9fe3a81 /configure.ac
parent0a8be3528787289767532dfb9b9cd25dff05b1e7 (diff)
downloadgstreamer-plugins-bad-dbfc737cd24f6d03e6488e4d2db2ec8114821138.tar.gz
configure.ac: Check for sufficiently up-to-date x264 API.
Original commit message from CVS: * configure.ac: Check for sufficiently up-to-date x264 API. * ext/x264/gstx264enc.c: (gst_x264_enc_pass_get_type), (gst_x264_enc_base_init), (gst_x264_enc_class_init), (gst_x264_enc_init), (gst_x264_enc_init_encoder), (gst_x264_enc_set_property), (gst_x264_enc_get_property): * ext/x264/gstx264enc.h: Expose some more parameters of the x264 encoder as properties.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 17 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 6cc8aac11..eac91a3b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1056,10 +1056,23 @@ dnl *** x264 (MPEG-4 part 10/h.264/AVC encoder) ***
translit(dnm, m, l) AM_CONDITIONAL(USE_X264, true)
AG_GST_CHECK_FEATURE(X264, [x264 plug-in], x264, [
AG_GST_CHECK_LIBHEADER(X264, x264, x264_nal_encode, -lm, x264.h,
- X264_LIBS="$LDFLAGS -lx264 -lm"
- X264_CFLAGS="$CFLAGS"
- AC_SUBST(X264_LIBS)
- AC_SUBST(X264_CFLAGS))
+ AC_MSG_CHECKING([for uptodate x264 API version])
+ dnl _stdint not yet generated, so no compiling
+ AC_TRY_CPP([
+ #include <x264.h>
+ #if X264_BUILD < 55
+ #error "x264 build too old"
+ #endif
+ ], [
+ AC_MSG_RESULT(yes)
+ X264_LIBS="$LDFLAGS -lx264 -lm"
+ X264_CFLAGS="$CFLAGS"
+ AC_SUBST(X264_LIBS)
+ AC_SUBST(X264_CFLAGS)
+ ], [
+ AC_MSG_RESULT(no)
+ HAVE_X264=no
+ ]))
])
dnl *** XVID ***