summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGeorge Kiagiadakis <george.kiagiadakis@collabora.com>2015-02-04 17:12:48 +0100
committerMatthew Waters <matthew@centricular.com>2018-09-21 19:36:52 +1000
commite2f06326eac7c3c7fa9c0d5baf4bf9673fc93376 (patch)
treea251495f65b6ca099b271c607a879e015d445d71 /configure.ac
parent45fe050286d2228810a0dc1e19caad3e32f17765 (diff)
downloadgstreamer-plugins-bad-e2f06326eac7c3c7fa9c0d5baf4bf9673fc93376.tar.gz
Add new SCTP plugins (sctpenc/sctpdec)
https://bugzilla.gnome.org/show_bug.cgi?id=744863
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9de9d0834..326db3be7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2356,6 +2356,22 @@ AG_GST_CHECK_FEATURE(WEBRTC, [WebRTC], webrtc, [
])
])
+dnl *** usrsctp ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_SCTP, true)
+AG_GST_CHECK_FEATURE(SCTP, [sctp plug-in], sctp, [
+ AC_CHECK_HEADER(usrsctp.h, [
+ AC_CHECK_LIB(usrsctp, usrsctp_init, [
+ USRSCTP_LIBS="-lusrsctp"
+ AC_SUBST(USRSCTP_LIBS)
+ HAVE_SCTP=yes
+ ], [
+ HAVE_SCTP=no
+ ])
+ ], [
+ HAVE_SCTP=no
+ ])
+])
+
else
dnl not building plugins with external dependencies,
@@ -2440,6 +2456,7 @@ AM_CONDITIONAL(USE_X265, false)
AM_CONDITIONAL(USE_DTLS, false)
AM_CONDITIONAL(USE_VULKAN, false)
AM_CONDITIONAL(USE_TTML, false)
+AM_CONDITIONAL(USE_SCTP, false)
fi dnl of EXT plugins
@@ -2612,6 +2629,7 @@ gst-libs/gst/interfaces/Makefile
gst-libs/gst/isoff/Makefile
gst-libs/gst/codecparsers/Makefile
gst-libs/gst/mpegts/Makefile
+gst-libs/gst/sctp/Makefile
gst-libs/gst/uridownloader/Makefile
gst-libs/gst/wayland/Makefile
gst-libs/gst/webrtc/Makefile
@@ -2714,6 +2732,7 @@ ext/rsvg/Makefile
ext/resindvd/Makefile
ext/rtmp/Makefile
ext/sbc/Makefile
+ext/sctp/Makefile
ext/smoothstreaming/Makefile
ext/sndfile/Makefile
ext/soundtouch/Makefile
@@ -2750,6 +2769,8 @@ pkgconfig/gstreamer-mpegts.pc
pkgconfig/gstreamer-mpegts-uninstalled.pc
pkgconfig/gstreamer-player.pc
pkgconfig/gstreamer-player-uninstalled.pc
+pkgconfig/gstreamer-sctp.pc
+pkgconfig/gstreamer-sctp-uninstalled.pc
pkgconfig/gstreamer-wayland.pc
pkgconfig/gstreamer-wayland-uninstalled.pc
pkgconfig/gstreamer-webrtc.pc