summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFlavio Oliveira <flavio.oliveira@indt.org.br>2005-09-01 19:12:44 +0000
committerFlavio Oliveira <flavio.oliveira@indt.org.br>2005-09-01 19:12:44 +0000
commitea6821e2934fe8d356ea89d5610f0630b3446877 (patch)
tree37733daef4573c1ea2970a5ff298d528b581a381 /configure.ac
parente05ab72ace5e5f8210f68b469729bef810af54bd (diff)
downloadgstreamer-plugins-bad-ea6821e2934fe8d356ea89d5610f0630b3446877.tar.gz
Faac (AAC Encoder) ported for GStreamer 0.9CHANGELOG_START
Original commit message from CVS: Faac (AAC Encoder) ported for GStreamer 0.9
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 64b9741e1..8c0e9fa7e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -322,6 +322,14 @@ dnl ###########################
dnl # Configure external libs #
dnl ###########################
+dnl **** Free AAC Encoder (FAAC) ****
+translit(dnm, m, l) AM_CONDITIONAL(USE_FAAC, true)
+GST_CHECK_FEATURE(FAAC, [AAC encoder plug-in], faac, [
+ GST_CHECK_LIBHEADER(FAAC, faac, faacEncOpen, -lm, faac.h, FAAC_LIBS="-lfaac -lm")
+ AS_SCRUB_INCLUDE(FAAC_CFLAGS)
+ AC_SUBST(FAAC_LIBS)
+])
+
dnl **** Free AAC Decoder (FAAD) ****
translit(dnm, m, l) AM_CONDITIONAL(USE_FAAD, true)
GST_CHECK_FEATURE(FAAD, [AAC decoder plug-in], faad, [
@@ -414,6 +422,7 @@ gst/Makefile
gst/qtdemux/Makefile
sys/Makefile
ext/Makefile
+ext/faac/Makefile
ext/faad/Makefile
common/Makefile
common/m4/Makefile