summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Waters <matthew@centricular.com>2014-10-17 15:22:24 +0200
committerMatthew Waters <matthew@centricular.com>2014-11-28 09:14:25 +1100
commitf2af65ee2de5bb8d2ba97af3f0562e23d8c86144 (patch)
tree40f702ca1ce951488dbc179fde68ee76d32a3779 /configure.ac
parent480d3f97ebda815837398833af8a437663254765 (diff)
downloadgstreamer-plugins-bad-f2af65ee2de5bb8d2ba97af3f0562e23d8c86144.tar.gz
gl: add a sync meta for synchronizing across GL contexts
A context can create a GLsync object that can be waited on in order to ensure that GL resources created in one context are able to be used in another shared context without any chance of reading invalid data. This meta would be placed on buffers that are known to cross from one context to another. The receiving element would then wait on the sync object to ensure that the data to be used is complete.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 38c9c0553..674bbb7de 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1293,6 +1293,7 @@ GST_GL_HAVE_GLEGLIMAGEOES=0
GST_GL_HAVE_GLCHAR=0
GST_GL_HAVE_GLSIZEIPTR=0
GST_GL_HAVE_GLINTPTR=0
+GST_GL_HAVE_GLSYNC=0
old_CFLAGS=$CFLAGS
CFLAGS="$GL_CFLAGS $CFLAGS"
@@ -1317,6 +1318,11 @@ if test "x$ac_cv_type_GLintptr" = "xyes"; then
GST_GL_HAVE_GLINTPTR=1
fi
+AC_CHECK_TYPES(GLsync, [], [], [[$GL_INCLUDES]])
+if test "x$ac_cv_type_GLsync" = "xyes"; then
+ GST_GL_HAVE_GLSYNC=1
+fi
+
CFLAGS=$old_CFLAGS
GL_CONFIG_DEFINES="$GL_CONFIG_DEFINES
@@ -1324,6 +1330,7 @@ GL_CONFIG_DEFINES="$GL_CONFIG_DEFINES
#define GST_GL_HAVE_GLCHAR $GST_GL_HAVE_GLCHAR
#define GST_GL_HAVE_GLSIZEIPTR $GST_GL_HAVE_GLSIZEIPTR
#define GST_GL_HAVE_GLINTPTR $GST_GL_HAVE_GLINTPTR
+#define GST_GL_HAVE_GLSYNC $GST_GL_HAVE_GLSYNC
"
AC_CONFIG_COMMANDS([gst-libs/gst/gl/gstglconfig.h], [