summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJustin Kim <justin.kim@collabora.com>2017-07-31 14:38:34 +0900
committerOlivier CrĂȘte <olivier.crete@collabora.com>2017-11-07 14:34:48 -0500
commitf78be9d6988b1c3d1482a981c94a545e79645e43 (patch)
tree3ca93e95f59c9bfc8411eb290258d9d5971deb7d /configure.ac
parent07819afda461f5e4d77c9be9f484a7aae3c5ec8c (diff)
downloadgstreamer-plugins-bad-f78be9d6988b1c3d1482a981c94a545e79645e43.tar.gz
srt: Introduce SRT source and sink
SRT[0] is an open source transport technology[1] that optimizes streaming performance across unpredictable networks. Although SRT is based on UDP, it works like connection-oriented protocol. However, it doesn't mean that the SRT server or client is necessarily to link to a receiver or a sender so, here, the pairs of source and sink elements are introduced. - srtserversink: SRT server to feed SRT stream - srtclientsrc: SRT client to get SRT stream from srtserversink - srtclientsink: SRT client to send SRT stream - srtserversrc: SRT server to listen from srtclientsink [0] https://github.com/Haivision/srt [1] http://www.srtalliance.org/ https://bugzilla.gnome.org/show_bug.cgi?id=785730
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3b5c4fbe3..60afdfb6f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2533,6 +2533,15 @@ AG_GST_CHECK_FEATURE(LIBMMS, [mms protocol library], libmms, [
])
AC_SUBST(LIBMMS_LIBS)
+dnl *** libsrt ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_SRT, true)
+AG_GST_CHECK_FEATURE(SRT, [srt library], srt, [
+ PKG_CHECK_MODULES(SRT, libsrt, HAVE_SRT="yes",
+ AG_GST_CHECK_LIBHEADER(SRT, srt, srt_startup, , srt/srt.h, SRT_LIBS="-lsrt")
+ )
+ AC_SUBST(SRT_LIBS)
+ AC_SUBST(SRT_CFLAGS)
+])
dnl *** libsrtp ***
translit(dnm, m, l) AM_CONDITIONAL(USE_SRTP, true)
@@ -3793,6 +3802,7 @@ ext/smoothstreaming/Makefile
ext/sndfile/Makefile
ext/soundtouch/Makefile
ext/spandsp/Makefile
+ext/srt/Makefile
ext/srtp/Makefile
ext/teletextdec/Makefile
ext/gme/Makefile