summaryrefslogtreecommitdiff
path: root/ext/Makefile.am
diff options
context:
space:
mode:
authorMatthew Waters <matthew@centricular.com>2014-12-18 17:00:30 +1100
committerMatthew Waters <matthew@centricular.com>2015-06-11 22:01:03 +1000
commit23fb666dd745b0fb6a9fb936b6e735c35e9cfd6a (patch)
tree583f76beeef068c617f2eaf1602a4652d8cef97f /ext/Makefile.am
parent898b43621982175baba86fd02eadccf3af6c1091 (diff)
downloadgstreamer-plugins-bad-23fb666dd745b0fb6a9fb936b6e735c35e9cfd6a.tar.gz
Implement gtk sinks
two sinks are provided. gtksink which is a cairo/software based renderer and gtkglsink which utilises the GL support in gtk and gstreamer.
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
index 394c71df2..66dccd6b6 100644
--- a/ext/Makefile.am
+++ b/ext/Makefile.am
@@ -88,6 +88,12 @@ else
GL_DIR=
endif
+if USE_GTK3
+GTK3_DIR=gtk
+else
+GTK3_DIR=
+endif
+
if USE_RESINDVD
RESINDVD_DIR = resindvd
else
@@ -436,6 +442,7 @@ SUBDIRS=\
$(DTS_DIR) \
$(RESINDVD_DIR) \
$(GL_DIR) \
+ $(GTK3_DIR) \
$(FAAC_DIR) \
$(FAAD_DIR) \
$(FLITE_DIR) \
@@ -516,6 +523,7 @@ DIST_SUBDIRS = \
daala \
dts \
gl \
+ gtk \
modplug \
mimic \
mpeg2enc \