summaryrefslogtreecommitdiff
path: root/ext/closedcaption/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2018-05-28 14:16:48 +0100
committerTim-Philipp Müller <tim@centricular.com>2018-05-28 14:17:05 +0100
commitaab111b9791ced63de6b324d902f99ca518d3edd (patch)
tree5977dff79d1c72d646d95f067b65e2377b2a5940 /ext/closedcaption/meson.build
parent2a1553cb885303d21f796ce2297851fb72de6dcc (diff)
downloadgstreamer-plugins-bad-aab111b9791ced63de6b324d902f99ca518d3edd.tar.gz
closedcaption: fix meson build
Diffstat (limited to 'ext/closedcaption/meson.build')
-rw-r--r--ext/closedcaption/meson.build9
1 files changed, 8 insertions, 1 deletions
diff --git a/ext/closedcaption/meson.build b/ext/closedcaption/meson.build
index a149d23cd..841fab751 100644
--- a/ext/closedcaption/meson.build
+++ b/ext/closedcaption/meson.build
@@ -1,8 +1,15 @@
pangocairo_dep = dependency('pangocairo', version : '>= 1.22.0', required : false)
+zvbi_sources = [
+ 'bit_slicer.c',
+ 'decoder.c',
+ 'raw_decoder.c',
+ 'sampling_par.c',
+]
+
if pangocairo_dep.found()
gstclosedcaption = library('gstclosedcaption',
- 'gstccextractor.c', 'gstclosedcaption.c',
+ 'gstccextractor.c', 'gstclosedcaption.c', 'gstline21dec.c', zvbi_sources,
c_args : gst_plugins_bad_args,
link_args : noseh_link_args,
include_directories : [configinc],