summaryrefslogtreecommitdiff
path: root/ext/svthevcenc/meson.build
diff options
context:
space:
mode:
authorYeongjin Jeong <yeongjin.jeong@navercorp.com>2019-03-23 21:01:51 +0900
committerGStreamer Merge Bot <gitlab-merge-bot@gstreamer-foundation.org>2019-12-20 15:43:55 +0000
commit663aeb2131a12d38a0729129ca8709645ca3afd5 (patch)
tree9bc01e6fa9a4ae896c90ec386278621738c2c946 /ext/svthevcenc/meson.build
parent3f2240498babef1fd906e9442f283a44a1caccdf (diff)
downloadgstreamer-plugins-bad-663aeb2131a12d38a0729129ca8709645ca3afd5.tar.gz
svthevcenc: Add new SVT-HEVC encoder element
The SVT-HEVC (Scalable Video Technology[0] for HEVC) Encoder is an open source video coding technology[1] that is highly optimized for Intel Xeon Scalable processors and Intel Xeon D processors. [0] https://01.org/svt [1] https://github.com/OpenVisualCloud/SVT-HEVC
Diffstat (limited to 'ext/svthevcenc/meson.build')
-rw-r--r--ext/svthevcenc/meson.build18
1 files changed, 18 insertions, 0 deletions
diff --git a/ext/svthevcenc/meson.build b/ext/svthevcenc/meson.build
new file mode 100644
index 000000000..9efe54b00
--- /dev/null
+++ b/ext/svthevcenc/meson.build
@@ -0,0 +1,18 @@
+svthevcenc_sources = [
+ 'gstsvthevcenc.c',
+]
+
+svthevcenc_dep = dependency('SvtHevcEnc', version : '>= 1.4.1', required: get_option('svthevcenc'))
+
+if svthevcenc_dep.found()
+ gstsvthevcenc = library('gstsvthevcenc',
+ svthevcenc_sources,
+ c_args : gst_plugins_bad_args + ['-DGST_USE_UNSTABLE_API'],
+ include_directories : [configinc],
+ dependencies : [gstbase_dep, gstpbutils_dep, gstvideo_dep, gstcodecparsers_dep, svthevcenc_dep],
+ install : true,
+ install_dir : plugins_install_dir,
+ )
+ pkgconfig.generate(gstsvthevcenc, install_dir : plugins_pkgconfig_install_dir)
+ plugins += [gstsvthevcenc]
+endif