summaryrefslogtreecommitdiff
path: root/gst/debugutils/meson.build
diff options
context:
space:
mode:
authorPhilippe Normand <philn@igalia.com>2021-03-30 14:40:53 +0100
committerGStreamer Marge Bot <gitlab-merge-bot@gstreamer-foundation.org>2021-04-09 08:13:12 +0000
commit933ebba43535d75a3274f519cbcaf70863a9464c (patch)
treecaa1482ef8b0a39b0a3b06aa4ca6beefd102ee09 /gst/debugutils/meson.build
parentf992c521c382ee23e94148ad523bd5e7782f29a6 (diff)
downloadgstreamer-plugins-bad-933ebba43535d75a3274f519cbcaf70863a9464c.tar.gz
debugutils: Add fakeaudiosink element
This element can be useful for CI purposes on machines not running any system audio daemon. The element implements the GstStreamVolume interface. Part-of: <https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/merge_requests/2125>
Diffstat (limited to 'gst/debugutils/meson.build')
-rw-r--r--gst/debugutils/meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/gst/debugutils/meson.build b/gst/debugutils/meson.build
index c863556fe..d05161195 100644
--- a/gst/debugutils/meson.build
+++ b/gst/debugutils/meson.build
@@ -6,6 +6,7 @@ debugutilsbad_sources = [
'gstchecksumsink.c',
'gstchopmydata.c',
'gstcompare.c',
+ 'gstfakeaudiosink.c',
'gstfakevideosink.c',
'gstwatchdog.c',
'gsttestsrcbin.c',
@@ -16,7 +17,7 @@ gstdebugutilsbad = library('gstdebugutilsbad',
debugutilsbad_sources,
c_args : gst_plugins_bad_args,
include_directories : [configinc],
- dependencies : [gstbase_dep, gstvideo_dep, gstnet_dep],
+ dependencies : [gstbase_dep, gstvideo_dep, gstnet_dep, gstaudio_dep],
install : true,
install_dir : plugins_install_dir,
)