summaryrefslogtreecommitdiff
path: root/gst/debugutils/meson.build
diff options
context:
space:
mode:
authorEderson de Souza <ederson.desouza@intel.com>2019-10-23 10:11:46 -0700
committerEderson de Souza <ederson.desouza@intel.com>2019-11-06 08:58:53 -0800
commitfe8e2a001cbea5a5aeacaa2f14371333902206be (patch)
tree42a43de9a09aab84c6baf29b8a83ba49c626833b /gst/debugutils/meson.build
parentd8f61515d84cfd05729f8064598f44bef2a82e69 (diff)
downloadgstreamer-plugins-bad-fe8e2a001cbea5a5aeacaa2f14371333902206be.tar.gz
debugutils: clockselect, a pipeline that enables clock selection
Sometimes, one wants to force a clock on some pipelines - for instance, when testing TSN related pipelines, one usually uses GstPtpClock or CLOCK_REALTIME (assuming system realtime clock is in sync with network one). Until now, one needs to write an application for that - not difficult, but quite boring if one just wants to test something. This patch presents a new element to help that: clockselect. clockselect is a pipeline with two properties to select a clock. One property, "clock-id", enables one to choose between "monotonic", "realtime", "ptp" or "default" clock - where default keeps pipeline behaviour of choosing a clock based on its elements. The other property, "ptp-domain" gives one the choice of which PTP domain should be used. Some very simple tests also added for this new element.
Diffstat (limited to 'gst/debugutils/meson.build')
-rw-r--r--gst/debugutils/meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/gst/debugutils/meson.build b/gst/debugutils/meson.build
index 4c003c8e7..c863556fe 100644
--- a/gst/debugutils/meson.build
+++ b/gst/debugutils/meson.build
@@ -9,13 +9,14 @@ debugutilsbad_sources = [
'gstfakevideosink.c',
'gstwatchdog.c',
'gsttestsrcbin.c',
+ 'gstclockselect.c',
]
gstdebugutilsbad = library('gstdebugutilsbad',
debugutilsbad_sources,
c_args : gst_plugins_bad_args,
include_directories : [configinc],
- dependencies : [gstbase_dep, gstvideo_dep],
+ dependencies : [gstbase_dep, gstvideo_dep, gstnet_dep],
install : true,
install_dir : plugins_install_dir,
)