summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMatthew Waters <matthew@centricular.com>2019-11-27 00:25:16 +1100
committerGStreamer Merge Bot <gitlab-merge-bot@gstreamer-foundation.org>2019-11-28 23:27:21 +0000
commit24d096597b6073c314b56a511d366ccde746a8fd (patch)
tree5da6e030d3f2c9b15614ac9aa1efe4f61994b8e1 /meson.build
parent5177c24a7eb59b28022a696d483f540fe489f221 (diff)
downloadgstreamer-plugins-bad-24d096597b6073c314b56a511d366ccde746a8fd.tar.gz
vulkan: implement caching and reuse of a couple of vulkan resources
Includes a new GstVulkanHandlePool base class for pooling different resources togther. The descriptor cache object is ported to GstVulkanHandlePool with the exact same functionality. A new GstVulkanFenceCache is also implemented for caching fences which is used internally by GstVulkanDevice for creating or reusing fences. The existing GstVulkanTrashFenceList object now caches trash objects.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 6eabbf1bc..2432f879b 100644
--- a/meson.build
+++ b/meson.build
@@ -377,6 +377,7 @@ else
message('Orc Compiler not found or disabled, will use backup C code')
cdata.set('DISABLE_ORC', 1)
endif
+cdata.set('GST_ENABLE_EXTRA_CHECKS', get_option('extra-checks'))
gnustl_dep = declare_dependency()
if host_system == 'android'