summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2020-04-03 17:07:47 +0530
committerNirbheek Chauhan <nirbheek@centricular.com>2020-04-03 17:07:47 +0530
commit387b6df948a566ca8d6318b58029f66499ffb1c2 (patch)
tree2327108973c2e12047b861257ef08cf577e17f9c /meson.build
parent1f62fe1cbc8e489bc098854dce3cd21c44d8425e (diff)
downloadgstreamer-plugins-bad-387b6df948a566ca8d6318b58029f66499ffb1c2.tar.gz
meson: Don't use get_option('buildtype')
We should directly check the values of the `debug` and `optimization` options instead. `get_option('buildtype')` will return `'custom'` for most combinations of `-Doptimization` and `-Ddebug`, but those two will always be set correctly if only `-Dbuildtype` is set. So we should look at those options directly. For the two-way mapping between `buildtype` and `optimization` + `debug`, see this table: https://mesonbuild.com/Builtin-options.html#build-type-options
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 92b271025..5f992891b 100644
--- a/meson.build
+++ b/meson.build
@@ -1,6 +1,6 @@
project('gst-plugins-bad', 'c', 'cpp',
version : '1.17.0.1',
- meson_version : '>= 0.48',
+ meson_version : '>= 0.49',
default_options : [ 'warning_level=1',
'buildtype=debugoptimized' ])