summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThibault Saunier <tsaunier@igalia.com>2018-10-22 11:30:45 +0200
committerThibault Saunier <tsaunier@igalia.com>2019-05-13 17:00:00 -0400
commit47a49f33815dbe3db7c1f7fa8f528d9bd0b83d8c (patch)
treeef8cce7a2344781ed189cbce89f386506fe49452 /meson.build
parent5a2b9357c94b9e07726d1bf6cf8ce1810ba8dad2 (diff)
downloadgstreamer-plugins-bad-47a49f33815dbe3db7c1f7fa8f528d9bd0b83d8c.tar.gz
docs: Build documentation with hotdoc
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 2ae7f1d5c..897532ede 100644
--- a/meson.build
+++ b/meson.build
@@ -1,6 +1,6 @@
project('gst-plugins-bad', 'c', 'cpp',
version : '1.17.0.1',
- meson_version : '>= 0.47',
+ meson_version : '>= 0.48',
default_options : [ 'warning_level=1',
'buildtype=debugoptimized' ])
@@ -29,6 +29,7 @@ libversion = '@0@.@1@.0'.format(soversion, curversion)
osxversion = curversion + 1
plugins_install_dir = join_paths(get_option('libdir'), 'gstreamer-1.0')
+plugins = []
cc = meson.get_compiler('c')
cxx = meson.get_compiler('cpp')
@@ -437,3 +438,5 @@ endif
configure_file(output : 'config.h', configuration : cdata)
run_command(python3, '-c', 'import shutil; shutil.copy("hooks/pre-commit.hook", ".git/hooks/pre-commit")')
+
+subdir('docs')