summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2020-07-08 11:39:58 +0100
committerTim-Philipp Müller <tim@centricular.com>2020-07-08 11:39:58 +0100
commit4c4b3dfc76b73f9fbadda944604dfd3208c96ed3 (patch)
tree332906dd815961a97218f3dfc8493bb7ad3010a0 /meson.build
parentb428b7357ea066b25334ae3d9538fbcf8fe27ef3 (diff)
downloadgstreamer-plugins-bad-4c4b3dfc76b73f9fbadda944604dfd3208c96ed3.tar.gz
meson: Fix up update-orc-dist target for the case where there are no orc targets
All those plugins might have been disabled, in which case meson would complain about alias_target() needing at least two arguments. Part-of: <https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/merge_requests/1418>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 4c2649a14..b0c8a85c6 100644
--- a/meson.build
+++ b/meson.build
@@ -465,7 +465,7 @@ if have_orcc
]
endforeach
- if meson.version().version_compare('>= 0.52')
+ if meson.version().version_compare('>= 0.52') and orc_update_targets.length() > 0
update_orc_dist_target = alias_target('update-orc-dist', orc_update_targets)
endif
endif