summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSeungha Yang <seungha.yang@navercorp.com>2018-11-24 19:26:30 +0900
committerSeungha Yang <seungha.yang@navercorp.com>2018-11-24 19:26:30 +0900
commit4de06ea12ca4a1066ff05a72c183139c4dfe2e94 (patch)
treef2714a06141235a03e6e0d71ae4f11b3dd78d5ee /meson.build
parent09dbe83e5d14d137d200959d408329e140550749 (diff)
downloadgstreamer-plugins-bad-4de06ea12ca4a1066ff05a72c183139c4dfe2e94.tar.gz
meson: Specify encoding to UTF-8 when building with MSVC
Use build arguments consistent with core and -base. This can also remove noisy "C4819" warning of non-us locale MSVC.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9fd859d48..7346e1829 100644
--- a/meson.build
+++ b/meson.build
@@ -44,6 +44,7 @@ if cc.get_id() == 'msvc'
'/wd4146', # unary minus on unsigned (beware INT_MIN)
'/wd4244', # lossy type conversion (e.g. double -> int)
'/wd4305', # truncating type conversion (e.g. double -> float)
+ cc.get_supported_arguments(['/utf-8']), # set the input encoding to utf-8
]
add_project_arguments(msvc_args, language : 'c')
add_project_arguments(msvc_args, language : 'cpp')