summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2017-06-26 09:52:24 +0100
committerTim-Philipp Müller <tim@centricular.com>2017-06-26 09:52:24 +0100
commit4f9163c06cd27ce12c4c69c2f6916f85fe64c760 (patch)
tree87a2a467da68e8f7a6435da5445d126812c3d1ee /meson.build
parent5a8ffe2aa33e312b5e2afbc05da4e83549084704 (diff)
downloadgstreamer-plugins-bad-4f9163c06cd27ce12c4c69c2f6916f85fe64c760.tar.gz
meson: fix with-package-name option
https://bugzilla.gnome.org/show_bug.cgi?id=784082
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 4 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index cc6f245de..4ae32c609 100644
--- a/meson.build
+++ b/meson.build
@@ -257,13 +257,14 @@ cdata.set('LIBDIR', '"@0@"'.format(get_option('libdir')))
gst_package_name = get_option('with-package-name')
if gst_package_name == ''
if gst_version_nano == 0
- cdata.set_quoted('GST_PACKAGE_NAME', 'GStreamer Bad Plug-ins source release')
+ gst_package_name = 'GStreamer Bad Plug-ins source release'
elif gst_version_nano == 1
- cdata.set_quoted('GST_PACKAGE_NAME', 'GStreamer Bad Plug-ins git')
+ gst_package_name = 'GStreamer Bad Plug-ins git'
else
- cdata.set_quoted('GST_PACKAGE_NAME', 'GStreamer Bad Plug-ins prerelease')
+ gst_package_name = 'GStreamer Bad Plug-ins prerelease'
endif
endif
+cdata.set_quoted('GST_PACKAGE_NAME', gst_package_name)
cdata.set_quoted('GST_PACKAGE_ORIGIN', get_option('with-package-origin'))
# FIXME: This should be exposed as a configuration option