summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorScott D Phillips <scott.d.phillips@intel.com>2016-11-17 17:17:22 -0800
committerTim-Philipp Müller <tim@centricular.com>2016-11-18 09:39:59 +0000
commit62fb78d084217d6c284dd4fcb2b184abacb96566 (patch)
tree47f66683b165e314855a8580b646d5f436c491ac /meson.build
parent1f6b96410aa77c0a2efae9751e143d92ecd68d8a (diff)
downloadgstreamer-plugins-bad-62fb78d084217d6c284dd4fcb2b184abacb96566.tar.gz
meson: add_global_arguments -> add_project_arguments
https://bugzilla.gnome.org/show_bug.cgi?id=774656
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 7 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 04ba44180..eecd37cfa 100644
--- a/meson.build
+++ b/meson.build
@@ -1,6 +1,6 @@
project('gst-plugins-bad', 'c', 'cpp',
version : '1.11.0.1',
- meson_version : '>= 0.33.0',
+ meson_version : '>= 0.36.0',
default_options : [ 'warning_level=1',
'buildtype=debugoptimized' ])
@@ -33,9 +33,12 @@ if cc.get_id() == 'msvc'
# If a warning is completely useless and spammy, use '/wdXXXX' to suppress it
# If a warning is harmless but hard to fix, use '/woXXXX' so it's shown once
# NOTE: Only add warnings here if you are sure they're spurious
- if not meson.is_subproject()
- add_global_arguments('/wd4018', '/wd4146', '/wd4244', '/wd4333', '/wd4996', language : 'c')
- endif
+ add_project_arguments(
+ '/wd4018', # implicit signed/unsigned conversion
+ '/wd4146', # unary minus on unsigned (beware INT_MIN)
+ '/wd4244', # lossy type conversion (e.g. double -> int)
+ '/wd4305', # truncating type conversion (e.g. double -> float)
+ language : 'c')
# Disable SAFESEH with MSVC for plugins and libs that use external deps that
# are built with MinGW
noseh_link_args = ['/SAFESEH:NO']