summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSaunier Thibault <saunierthibault@gmail.com>2015-12-03 12:32:05 +0100
committerThibault Saunier <tsaunier@gnome.org>2019-08-28 13:02:13 +0000
commit7a66b16d976468fcf72c2d1398fd637bdb4e348c (patch)
tree6a2d09ec58ab6bd964135cca665814805bbcbfaa /meson.build
parent87311d404ef75c08fc8417fc7fb41e17002e80f6 (diff)
downloadgstreamer-plugins-bad-7a66b16d976468fcf72c2d1398fd637bdb4e348c.tar.gz
Import GstTranscoder
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 8 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 6a2ba6bd3..67aeeb4d0 100644
--- a/meson.build
+++ b/meson.build
@@ -147,10 +147,15 @@ check_functions = [
['HAVE_GMTIME_R', 'gmtime_r'],
['HAVE_MMAP', 'mmap'],
['HAVE_PIPE2', 'pipe2'],
+ ['HAVE_GETRUSAGE', 'getrusage', '#include<sys/resource.h>'],
]
foreach f : check_functions
- if cc.has_function(f.get(1))
+ prefix = ''
+ if f.length() == 3
+ prefix = f.get(2)
+ endif
+ if cc.has_function(f.get(1), prefix: prefix)
cdata.set(f.get(0), 1)
endif
endforeach
@@ -427,6 +432,8 @@ subdir('gst')
subdir('sys')
subdir('ext')
subdir('tests')
+subdir('data')
+subdir('tools')
subdir('pkgconfig')
# xgettext is optional (on Windows for instance)